Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 2 voices.

Last updated by Bigul 4 months ago.

Assigned support staff: Bigul.

Author Posts
March 10, 2020 at 3:45 pm #5656051

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the feedback and login information. I have escalated the ticket to our second-tier team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

March 13, 2020 at 7:28 am #5677793

danielJ-8

Hi Bigul,
can you update me on this issue?
Thanks!
Daniel

March 13, 2020 at 1:11 pm #5680317

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Our developers are currently working on this issue. We have one more request for further debugging. Please create two test pages in the staging site and translate it via Memsource. Then import it back(automatically) and share the URLs with us. So we can reproduce the issue exactly on the staging site.

--
Thanks!

Bigul

March 16, 2020 at 9:04 am #5691571

danielJ-8

Hi Bigul,

I have created and translated in Memsource two more test pages:

hidden link

hidden link

You will still see translations, because I have not on "Translate target links".

Please let me know asap!
Thanks
Daniel

March 16, 2020 at 10:34 am #5692333

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates. I have shared the details with our second-tier team and waiting for their feedback now. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

March 20, 2020 at 6:36 am #5725605

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

This is happening because of compatibility conflict with Memsource Translation Plugin for WordPress - https://wordpress.org/plugins/memsource-connector/ plugin. Also, Memsoruce is not the translation service and it is a kind of Translation Proxy. Memsource Translation plugin is not updating the page contents in WPML Translation Editor.

So as a workaround we have to turn off the Translation Editor option for the page translated or translating with Memsource. Please open a Page for edit and turn off the *WPML’s Translation Editor* option of WPML Language edit(on the right side of the screen).

Please try it after a full site backup and let me know your feedback.

Please check the following documentation and image URLs for more details.

https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

https://wpml.org/wp-content/uploads/2019/01/wpml-use-the-wordpress-editor-to-translate.png

https://wpml.org/wp-content/uploads/2019/01/wpml-turn-off-wpml-translation-editor-156x300.png

--
Thanks!

Bigul

March 20, 2020 at 9:00 am #5726379

danielJ-8

Hi Bigul.
I tried that. Yes, the WPML Editor can be deactivated, but when you click on "Settings>Translate target link" all translations disappear.

Memsource is not a translation service and it is not a translation proxy. Memsource is translation memory platform for companies and translation agencies.

I want to contact the Memsource tech support and let them know about this. Please tell me how to proceed so that Memsource developers can get in touch with you. You will explain them what the issue is about much better than me.

Regards,
Daniel

March 20, 2020 at 10:59 am #5727335

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates. I have shared the details with our developers and waiting for their expert opinion.

We would like to know the issue is happening in the following case. Please try it and let me know your feedback.

1) Create a Test Page
2) Turn Off the WPML Translation Editor option for it - https://wpml.org/wp-content/uploads/2019/01/wpml-turn-off-wpml-translation-editor-156x300.png
3) Send the Page for translation to Memsource
4) Complete the translation
5) Visit WPML>>Settings>>Translate Link Targets
6) Click on *Scan now and adjust links* button

--
Thanks!

Bigul

March 20, 2020 at 4:05 pm #5729289

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Please share the following URLs with Memsource tech support. They can apply for our plugin compatibility program and Translation service integration.

https://wpml.org/documentation/theme-compatibility/go-global-program/

https://wpml.org/announcements/2013/11/wpml-project-invites-translation-services-join/

It will help to make the Memsource translation service and its plugin fully compatible with WPML.

--
Thanks!

Bigul

March 27, 2020 at 8:09 am #5776105

danielJ-8

Hi,
can you please explain in detail why you say there is a compatibility issue between Memsource and WPML?

If we deactivate the WPML Editor on Pages and Posts, we eliminate the chance of translation being deleted when you save changes on that editor. Since translations from Memsource do not appear on the WPML translation Editor, if you click on Save the source content appears and translation are deleted.

So now the issue is with the Option:

**Visit WPML>>Settings>>Translate Link Targets**

Why exactly do translations disappear when you click on this option?

Is there a way you fix this? Or is there something Memsource developers can adjust to avoid this?

Thanks!
Daniel

March 27, 2020 at 1:56 pm #5780089

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

The issue is happening because Memsource not using WPML Translation Proxy like the rest of translation services integrated with WPML - https://wpml.org/translation-service/. Therefore the Memsoruce updates the content directly in page/post and not in the Translation Editor format. Because of it when we run the Translate Link Targets, WPML updates the translated content from Translation Editor with adjusted links and it results in clearing the contents added by Memsource.

So as a workaround, for the time being, we have to choose *Manual Translation* option - https://wpml.org/wp-content/uploads/2019/01/wpml-turn-off-wpml-translation-editor-156x300.png for the pages that are translating with Memsource. Otherwise, it will be cleared if we run Translate Link Targets.

Our compatibility/Translation service team is happy to collaborate with the Memsource team to fix this issue if they can apply for our plugin compatibility program and Translation service integration. Please check the following URLs for more details and share them with Memsource tech support.

https://wpml.org/documentation/theme-compatibility/go-global-program/

https://wpml.org/announcements/2013/11/wpml-project-invites-translation-services-join/

--
Thanks!

Bigul

March 27, 2020 at 3:57 pm #5781193

danielJ-8

Hi Bigul,

as I said already, the *Manual Translation" option IS NOT solving this issue. Even if I disable the WPML Translation Editor, when I click on "Translate Link Targets" all translations imported from Memsource disappear. So there is no workaround so far.

Regards,
Daniel

March 27, 2020 at 4:33 pm #5781377

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates. So the issue is happening after the following steps also, am I right.

1) Create a Test Page
2) Turn Off the WPML Translation Editor option for it - https://wpml.org/wp-content/uploads/2019/01/wpml-turn-off-wpml-translation-editor-156x300.png
3) Send the Page for translation to Memsource
4) Complete the translation
5) Visit WPML>>Settings>>Translate Link Targets
6) Click on *Scan now and adjust links* button

Please share with me the correct credentials to access your staging site. Because now we are getting the following warning while login.

ERROR: la contraseña que has introducido para el nombre de usuario **** no es correcta. ¿Has olvidado tu contraseña?

--
Thanks!

Bigul

March 27, 2020 at 5:58 pm
March 28, 2020 at 8:02 am #5784565

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates and login information. I have updated our second-tier team about this. We will debug it further and get back to you as early as possible. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] When I click on Translate Link Target all translation saved in Pages are lost’ is closed to new replies.