This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user was having some alerts in SEO audit tools(SEM Rush SEO) Solution: The user's theme does not implement the lang attribute in Tag. See https://wpml.org/forums/topic/when-i-click-to-update-translation-i-get-duplicate-translation/#post-4666553 The user should ask audit tools for more explanation about the issues.

This topic contains 10 replies, has 4 voices.

Last updated by jassim mohammad 1 week, 4 days ago.

Assigned support staff: Jamal.

Author Posts
September 17, 2019 at 7:56 am #4586207

jassim mohammad

While i am under the English version of my WP website, when i click on the circle arrow to update the translation of the page content, the Semrush Seo check, as well as google search console, gives me page errors: duplicate content.

For example, if i am translating into Chinese, i will get an error like duplicate content. as if I am doing Chinese under the English version even though the text is in two different languages. So what i ended doing is open a page under the Chinese version and place the new translated text to avoid this issue.

Is there something wrong that i am not aware of regarding the translation update procedure?

(The attached file is the circle arrows where i click to update the translation.)

September 17, 2019 at 4:59 pm #4590333

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Clarifications:

1. Please upload a screenshot of the error that you are describing. Take care that the image is < 1M otherwise it will not load onto the forum.

2. Are you using the Translation Editor to make your translations?

3. Do the completed translations show up correctly on a completely translated page? And then you get the SEM Rush SEO check error?

Thanks

September 17, 2019 at 5:44 pm #4590473

jassim mohammad

Hi- i used the translation editor that takes me to the WPML translation site, and i add the translation manually, then i click 'complete' and it takes me back to the backend.

The other issue that creates an SEO problem, is if i wrote the page name in another Chinese or Arabic, I get scribbled URL like -

hidden link

if i decided to name the page in English under the second language, i will get a duplicate content flag error.

any suggestions?

Thanks

September 17, 2019 at 6:27 pm #4590701

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for the image.

The URLs seem to be all mixed up with the language directory "ar" (normally arabic) being assigned to zh-hans!

In this ticket, we are going to handle the issue about how you are creating the translations - for your other questions/issues, please open new tickets for each as our support policy limits the number of issues handled in each forum thread to a single topic.

I would like to try to recreate and understand this problem. Could you please create for me a simple test page with just a text box as content. Then write back with the name of the post and system access details (username/password with wp-admin/administrator access).

Is this ok?
I am opening the private area for this information.

September 18, 2019 at 6:14 pm #4599503

jassim mohammad

to be able to create a login credentials for you i will need an email. or you may sign up and i change your role to admin.

September 23, 2019 at 8:30 am #4621585

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

As Alejandro is not available today, I can replace him.
Unfortunately, the login/password you provided is not working for me. I tried to signup for your website and get back to you to make me admin without success.

Please update the first user password or create another user for me. Check my email in the attached image.

Best regards,
Jamal

September 24, 2019 at 4:09 pm #4632989

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I checked the homepage and the pricing page:
- hidden link
- hidden link
Both seem correct for me, they generate correct canonical and hreflang links in all languages.

<link rel="canonical" href="<em><u>hidden link</u></em>" />
<link rel="alternate" hreflang="en" href="<em><u>hidden link</u></em>" />
<link rel="alternate" hreflang="ar" href="<em><u>hidden link</u></em>" />
<link rel="alternate" hreflang="zh-hans" href="<em><u>hidden link</u></em>" />
<link rel="alternate" hreflang="es" href="<em><u>hidden link</u></em>" />

Can you give other examples or approach "Semrush Seo check" support to give us more details on their errors?

Best regards,
Jamal

September 25, 2019 at 10:40 am #4637961

jassim mohammad

If you kindly look at the message i send to Yvett few days ago, it has examples of href flag issues.

September 25, 2019 at 10:44 am #4637969
jassim mohammad

One more thing. If i have a page the i want to translate to arabic or chinese, the url will show letters and numbers. If i write it the url in english under the lang code i will get dupkicate content. How to resolve this issue.

Thanks

New threads created by Jamal and linked to this one are listed below:

https://wpml.org/forums/topic/translation-creates-duplicated-content/

September 30, 2019 at 4:28 pm #4666553

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I have indeed checked examples from the screenshot you sent to Yvette before. As far as I can tell, the tags that should handle translation from an SEO point of view are generated correctly.

What I can spot for the moment, is the fact that your theme uses a <html> tag without any language attributes. If you check the source code of wpml.org, you will notice a <html lang="en-US" > your theme only generates <html> without the lang attribute.

I suggest you update your theme's header.php file and change line 7 from

<html >

to

<html <?php language_attributes(); ?> >

Apart from that please reach out to "Semrush Seo check" support to give us more details on their errors?

Regarding the issue you discussed in the latest message, I have created another ticket to handle it. I'll be posting my replies there.

Best regards,
Jamal

October 6, 2019 at 12:52 pm #4702469

jassim mohammad

My issue is resolved now. Thank you!