Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 31 replies, has 7 voices.

Last updated by Yvette 1 year, 4 months ago.

Assigned support staff: Yvette.

Author Posts
March 28, 2019 at 7:13 pm #3485151

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)

Hello

The 2nd tier supporter has asked you to do the following steps:

- Please clear your cache or test in incognito.
- We´ve tried and asked other people to try
hidden link is redirecting only to
hidden link

I just tried in icognito mode and indeed, the problematic
hidden link does NOT redirect to hidden link

March 28, 2019 at 7:28 pm #3485185

julianZ-4

Hi Yvette

Thanks for your answer.

Of course I've used Inkognito and deleted all cache many times.

Seems that on hidden link the automatic redirect got manually deleted. (You can just click on yoast SEO tab -> redirects -> search for the redirect and delete it manually)

Of course, I can also manually delete the redirects on my site. But I don't want to manually delete a redirect after I publish a post on my site / change a URL

Please go again to hidden link create 1 new site and 1 new post in spanish, click on save, then change the URL of these two. You will create a new redirect and hidden link will no longer work in Inkognito mode or fresh browser (it might still work in your current browser, because the redirects are remembered)

I can't do it because the password is unfortunately no longer valid.

Best regards

Julian

March 28, 2019 at 7:37 pm #3485225

julianZ-4

I just found out how to log in.

I could easily replicate the error again:

Just: Create new post in Spanish language version. Then this appears: hidden link (see on top where it says it created a redirect from the frontpage to /test/..)

Now, in inkognito mode, you get redirected to: hidden link when you enter hidden link

When you try again in your browser you've used before, the redirect might not be in place yet. Use inkognito.

PLEASE HELP ME...

this is my 4th open ticket at the moment with a bug which is confirmed.

March 28, 2019 at 10:55 pm #3485985

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)

I am passing this new test case on to the compatibiltiy team as you have written it which is very clear.

March 29, 2019 at 8:09 am #3488705

julianZ-4

Thank you Yvette. I hope they can fix it soon.

March 29, 2019 at 1:56 pm #3491915

Ahmed Mohammed

Hi Julian,

This is Ahmed from the compatibility team. I'm sorry, this ticket should not take this long time, but I'm really having difficulties to reproduce the issue myself.

I need to reproduce the issue so that I can debug it.

When I delete your test redirect, I fail to reproduce it as you can see on the sandbox site. So, instead of re-creating the issue by yourself, let me list the steps I'm doing and I'll let you spot the step I miss during the reproducing problem:

1- First, I go to Posts and I change the language to Spanish.
2- I create a post with a title, Test Post, for example.
3- I edit the post slug to 'test-post-2'.
4- I notice a message from the system telling, a redirect has been created from the old URL to the new URL, and both URLs are correct.

Could you please review those steps and just tell me what am I missing?

Thanks a lot for the patience and for you help reproducing the issue.

March 29, 2019 at 2:23 pm #3492123

julianZ-4

Hi Ahmed

Thanks for your response.

It's even easier to reproduce.

1. Click on hidden link
2. Switch langauge to Spanish
3. Hover Posts -> Add new
4. Add title and content
5. Click publish

The error should be there.

March 29, 2019 at 2:31 pm #3492257

julianZ-4

Hi Ahmed

I just recorded a video for you to follow my steps.

Please note: You have to delete the first wrong redirect before you do the same. Else, the first redirect I created will stay in place. hidden link

Go to wp-admin -> yoast -> redirects -> delete the redirect for "/es"

After that, you can follow my videoguide or the steps from above: hidden link

April 1, 2019 at 4:04 pm #3509949

Ahmed Mohammed

Thanks a lot, Julian.

It's really easy to reproduce and I'm still not sure what was missing in my steps. Anyway, I can see the issue finally and I'll update you soon.

Regards,

April 1, 2019 at 8:59 pm #3511639

Ahmed Mohammed

Hi Julian,

The issue is coming from \WPSEO_Watcher::should_create_redirect; this condition does not take into consideration the language part

if ( $old_url !== $new_url && $old_url !== '/' && ( ! isset( $site['path'] ) || ( isset( $site['path'] ) && $old_url !== $site['path'] . '/' ) ) )

We'll be trying to handle it on our side or contact Yoast people to get it handled.

In the meantime, you can disable the automatic redirection creation by adding this line in your theme's functions.php

add_filter('wpseo_premium_post_redirect_slug_change', '__return_true' );

I hope this helps a bit until we get this resolved permanently.

Cheers,

April 2, 2019 at 7:42 am #3514437

julianZ-4

Hi Ahmed

Thanks a lot for the follow up!

As I need these redirects, I can't just use the workaround you described. I will have to manually delete the redirects.

Would it be possible to get informed as soon as this is solved? Then I can update the plugin.

Best regards and thanks

Julian

April 2, 2019 at 9:16 am #3515253

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)

Hello

Yes, the normal workflow will keep the status of the internal ticket until it is changed to "resolved". At this point, the change in status will notify me (the 1st tier supporter assigned) of a new action and I can then ping you.

However, in all cases, please also do not hesitate to "check-in" to see if there is any news on the ticket. I can always look at the status of the internal ticket and report on any notes I can see attached.

kind regards.

April 2, 2019 at 3:56 pm #3519001

julianZ-4

Thanks a lot Yvette. That's very good.

Best regards

Julian

April 26, 2019 at 1:44 pm #3691061

mertY-5

Hello Julian and Yvette,

I having exactly the same problem and any page I add makes my homepage inaccessible and redirects it to the new page.
This is not a simple bug, If I don't notice the Yoast Premium Redirect and Undo I might be sending all my homepage traffic to a new irrelevant page.

Has this issue been resolved?

Best Regards

Mert

June 26, 2020 at 6:58 pm #6463957

nadineO

I also have this exact issue, which still doesn't seem to be fixed. What's the current status?