This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: My translated page is showing duplicate content. How can I make it show the content just one time?

Solution: The duplicate content layout was fixed by duplicating the content block "Jugadores". Please make sure that content blocks are duplicated to your secondary language(s).

This topic contains 8 replies, has 3 voices.

Last updated by favioB 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 25, 2018 at 4:19 pm

favioB

I started to configured the pluging, but when in some point started to fail, and now when I enable the pluging all wordpress ajax interaction start to fail, and for example the translation of a page never save it.

I trying deleting all wpml plugins and I installed again, but the fail is persisting.

I am trying to: Save translations

Link to a page where the issue can be seen: hidden link

I expected to see: Save the translation

Instead, I got: A eternal waiting.

--
Besides.... I translate a portfolio post, but I don't know why the content is duplicated:
hidden link

And I can't figurate why.

September 26, 2018 at 8:56 pm #2768750

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

First, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Next, try upgrading your PHP version. If this does not resolve the issue, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, are you still seeing the issue?

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

September 26, 2018 at 9:00 pm #2768765

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This issue seems to happen because of low minimum requirements on your site.
By looking at the debug info that you have attached I can see that your server is running an older version of MySQL and also your server WP Memory Limit is set to 96M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if it help?

For the portfolio, English page issue here is what I did to fix it. I simply updated the English translation and now the English content shows. I did it on the link that you have sent me here.
hidden link
Please see the attached screenshot.
Can you see that now it is OK?

Regards,
Itamar.

September 29, 2018 at 1:15 pm #2775622

favioB

Thanks Lauren and Itamar.
First problem is solve, Thanks for that. But the second one I still have it.

The black box that show content on player-ok.jpg is the "footer" of the page, and below is the header, I do not know why the content is duplicated in all the page.

I tryed to fixed, and realize that if I try to translate manualy, without the Translation Editor, that it happened. If I use the Translation Editor since first creation moment, the duplication does not happend. But the Visual Composer has some text that Translation Editor does not appear. Subtitles of Higlights I can not edited with the Translation Editor. 🙁

How can I fixed?

September 29, 2018 at 1:33 pm #2775635

favioB

Sorry I was wrong, even with the Translation Editor I still have problem. I attach a image to show what is wrong

September 29, 2018 at 1:35 pm #2775648

favioB

The same happen on the Home Page.
hidden link

All the content is duplicated (without translation, because i didn't translated yet)

And in contact page: hidden link
The style of the page changed. hidden link And I don't know why.

🙁

October 1, 2018 at 2:01 pm #2778369

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please backup a working copy of site files and database before continuing.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

October 3, 2018 at 8:12 pm
October 4, 2018 at 9:20 pm #2788795

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Favio, thanks for sending the files. I set up a copy of your site and it turns out that the layout was fixed by duplicating the content block "Jugadores". Please try this on your live site and let me know if this resolves the issue. Thanks!

October 5, 2018 at 4:52 pm #2791369

favioB

My issue is resolved now. Thank you!