This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by joniK 3 weeks, 6 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 16, 2019 at 2:37 pm #4581569

joniK

I migrated my build site to a new directory (same server) and get the "When I enable WPML I get this error: PHP Fatal error: Uncaught Error: Call to undefined method stdClass::is_enabled()" error when enabling WMPL.

I found the topic on the forum and looked into the database to fix the wp-options table, but I don't know which value to change. I attacehd a screenshot that shows the wpml_language_switcher view on PHPMyAdmin.

P.s I can't provide the debug info, because when I enable WPML I can't access the dashboard.

Any pointers would be appreciated.

Thanks,

Joni

September 16, 2019 at 7:23 pm #4583637

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It seems something got corrupted during the migration, according the instructions of a similiar ticket at: https://wpml.org/forums/topic/fatal-error-when-activating-wpml-multilingual-cms-on-digital-ocean/ you need:

1 - Manually edit the 'wpml_language_switcher' field from the 'wp_options'.

2 - Make sure to replace the 'wpml_language_switcher' field content of your problematic WPML installation with the same values of your previous WPML working installation or any other WPML working installation.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it helps, have a nice day.

September 23, 2019 at 12:35 am #4619645

joniK

My issue is resolved now. Thank you!