This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When i go to the Mongolian version of the site and add an item to cart and go to checkout, the checkout will show an error message saying "Sorry, your session has expired. return to shop"

Solution: - Go to WPML -> Languages -> Language filtering for AJAX operations section -> Activate the option and save the changes.

Relevant Documentation:

0% of people find this useful.

This topic contains 4 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 23, 2019 at 2:50 pm #3877173

batmunkhB

I am trying to:It is too hard for me to fix it.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

May 23, 2019 at 2:52 pm #3877185

batmunkhB

When i go to the Mongolian version of the site and add an item to cart and go to checkout, the checkout will show an error message saying "Sorry, your session has expired. return to shop"

Please help me resolve this issue

May 23, 2019 at 2:56 pm #3877211

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Go to WPML -> Languages -> Language filtering for AJAX operations section -> Activate the option and save the changes.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

May 24, 2019 at 9:14 am #3882809

batmunkhB

My issue is resolved now.
After Language filtering for AJAX operations section -> Activated the option and saved the changes. the issue is gone.

Thank you!

May 24, 2019 at 9:44 am #3883015

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos