Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Alejandro 1 month ago.

Assigned support staff: Alejandro.

Author Posts
January 5, 2021 at 6:36 pm #7782257

davidP-23

Hello,

I translated all my content with Advanced Translation Editor. It Worked well, I can see the translated text in the front-end. However now when I re-send the content via ATE, instead of asking me to translate only the changed text, it asks me to translate everything. Like all the translations disappeared!

Where are the translation memory saved? How can I get them back?

Thanks,

David

January 5, 2021 at 7:07 pm #7782447

davidP-23

Here is a screenshot attached of a translated page and the same page in the ATE, where all the previously translated fields are empty.

January 7, 2021 at 12:25 pm #7793295

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

Can you tell me if you recently migrated your site from one place to another, if you reset WPML or something similar?

What happened to you usually happens because a new account for your site was created in the advanced translation editor. that happens in the back-end when you migrate a site for example and then select one of the 2 WPML options in the notification you probably got in the new site.

if that was the case, can you tell me which is the URL of the old domain so i can try to find it on our account and send its content over to your account?

January 10, 2021 at 11:21 am #7809173

davidP-23

Hello Alejandro,

Thanks you for your feedback.

So this is what I did recently, before the issue started:

1. I removed 2 languages from WPML as there were languages for test purposes and I was not using them:
- English (to be proofread) en-pr
- English (to review) en-us

2. I kept these languages
- French (fr) - original content
- English (en) - translated content via ATE from French
- German (de) - not translated yet

3. Later on I realized that when I was re-sending content to translation from French (fr) to English (en), the problem appeared. So here I thought that deleting the 2 other languages might have affect this somehow.

4. So I re-activated these 2 languages, but it did not solve the issue.

5. Then I also used a previous backup of my WordPress website I had from a few days ago (from when everything was working fine) and installed this backup over the actual wordpress website. But this did not solve the problem either.

Thanks for helping,

David

January 11, 2021 at 9:25 am #7813785

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I can see the English Language is "hidden". can you try to set it visible again and then:

- Go to the page that was initially correctly translated and then the translations disappear
- Update the page (make a small change to the title and save the page)
- Update the translation.

If the translation is empty. try to translate it again.

Then, set the English language as hidden again and try to see if the problem returns.

Always make sure your user profile (user > Your profile) has the checkbox that allows you to edit and see hidden content (otherwise you will encounter similar issues as the one you're describing) and let me know if the problem reappears.

With this procedure i'm trying to figure out if the problem could be located in the "hidden" status of the language.

Regards.

January 12, 2021 at 8:53 pm #7829491

davidP-23

Hi Alejandro,

I followed you instructions. I set the English language to be visible. Then I went to a page with the issue and updated the content and saved in the original language, then in the translated language. But the issue is still there when I try to translate via ATE, the translated content is not there. What should I do now?

January 13, 2021 at 8:02 am #7831629

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

May i please have credentials to access the site and the link of the pag that lost its content so i can try to figure out what happened?

you can use the credential fields that i have enabled for this purpose (they will only be available in this next reply).

Regards.

January 18, 2021 at 7:34 am #7865681

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

I think i know what happened (and the following information is the probable procedure thesis i could get from studying carefully the data that we have on our server + your data).

In our servers we have more or less 5-6 jobs for the same page. however the only one completed was one coming from "English US" to "English".

Those are the languages that were used in WPML, however the content in the source language of that page ("English US") was actually in French.

However you now tried to translated "French" to "English" which might have the same content but the translation memory here has no content at all because the content that you're looking for is stored in "English US".

So it's not really a bug, it's a procedure issue here.

I'm not sure about your workflow but it seems as you created a content in french but it was in the English US language, then you translated the content from there first and then you tried to translate the content from French.

In the front-end you would not really see that much the different because you only see the "target" language so you'd see the translation correctly, but the problem here is the source which should be "french" yet, in this case it was "English US".

The best way around this is to open at the same time the translation coming from English US and the French > EN translation and copy-paste the values so it gets stored once and for all in the correct place.

To avoid this issue from happening again, you might want to restrict your translation role to only translate from French into other languages, that way you won't mistakenly proceed without knowing the problem first.

Regards.

January 21, 2021 at 8:13 am #7894093

davidP-23

Hi Alejandro,

Thank you for looking into this in detail.

I am convinced I always chose French > English. There must have been a bug in the system.

I already spent countless hours to copy all my already translated content from the old editor to the ATE. Isn't there an automatic way of copying the translation memory from FR > English US to FR > English?

Thanks,

David

January 21, 2021 at 3:30 pm #7898605

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi there, i think the only way that might work here would be to map the languages in WPML > Translation Management > Translation tools > Language mappings

But this means that, if you had EN UK and EN US, the automatic translation editor would then pick-up US.

Here's the thing. even though for us humans, they are both English so they should be virtually the same, for the system, EN US and EN or EN UK, for example, would be 2 different things, 2 different languages with 2 different translations so they can't share the same translation memory.

We are working on a feature to export the translation memory from one language and import it wherever you want (in another language, in another CAT Tool, etc) but that's not yet ready so for now you would have to translate the content.

However, can you give me a few examples of pages that you are certain that you translated from FR > EN, to the correct English that now is giving you trouble? that way i can check our server and see if i can find a translation that contained the entire content so i can try to see if we can come up with a solution for this, depending on the outcome.

Regards.

January 22, 2021 at 5:31 pm #7908503

davidP-23

Hi Alejandro,

Thanks a lot for trying to solve this with me.

So I translated all the pages/posts under the custom post "Stations de ski" from French to English, e.g (Laax, Davos Klosters, Saas-Fee). These are all pages/posts where I translated with ATE from FR to EN, and where the most of the content is not in the translation memory anymore.

Thank you,

David

January 23, 2021 at 8:24 am #7911233

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

I checked the timeline of those translations in our system and found a pattern.

1) FR > EN seems to have never been fully translated for LAAX. only 34% was translated in the past since its creation.

However, you did fully translate the content from FR> EN-US, which i can, instead see as fully translated (in order for you to correctly translate and see the content in ATE, you need to make it visible, because if it's hidden you'll only see it in the classic translation editor).

2) Saas-fe was only missing 1 translation "a pied" for it to be 100% and since it was alone, i can suspect the only change there was just a colon or a dot or a newline somewhere that made the system separate it into a different segment (and this is expected, it's not a bug).

3) Davos Klosters: We had talked about this in the past and in here it turns out that the content appeared as translated from EN-US > EN, and in this case EN-US had the content in French. i can only guess in here it appeared in french because by thattime EN-US had not been translated yet the translation page existed (maybe it was empty) and it copied the content from French when sending it to translation (XLIFF files work in a way that when a translation doesn't exist, it copies the content from the source language, it's not something coming from WPML but from the way XLIFF files work).

Either that or the language mapping for the French language was set to EN-US.

Now, please watch this video: hidden link

With the method i'm howing there, you might be able to at least set the content in the front-end showing correctly, even though in the translation editor the translation memory still won't exist.

Please make sure you work on FR > EN and not on FR > EN-US or FR > EN To be proofread/reviewed since that means that the translation memory will remain on those languages and not on the other ones.

If you have a doubt and don't want the content to be published automatically (which seems to be the purpose of all those extra languages), you can go to WPML > Settings > Translated documents options > Document status > Draft.

That way you can review it first and only then, publish the content in the translated languages when you feel they are ready to be live.

Regards.