Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.85 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 3 voices.

Last updated by Yvette 2 years, 9 months ago.

Assigned support staff: Yvette.

Author Posts
November 15, 2017 at 12:57 pm

ramon

i am trying to navigate in the seconfd language of my website but it keeps getting error 500

November 16, 2017 at 7:32 pm #1433192

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello there,

Welcome to WPML support forum.

Please apologize for the delay in answering. This is not usual in this forum. While one of my teammates takes care of your case I will provide you with the first debugging steps.

Please, do the following test:
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

If the issue persists, it would be good if you can provide me the WordPress debug.log.

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

Thanks!

Let us know your results, please.

Kind Regards,

Otto

November 17, 2017 at 1:56 pm #1433946

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I connected to your site and reviewed the configuration errors in

Woocommerce -> Woocommerce Multilingual -> Status

It was reporting that you had not completely translated your permalink base for products.
I completed this required action.

Now I can navigate your site (in spite of the very annoying popup that keeps presenting itself) in all languages.

Please let us know if you are still having problems with the 500 error. If you have other problems, please open a new ticket for them.

Thanks

The topic ‘[Closed] when i save the permanent links works but i f5 and get error 500’ is closed to new replies.