This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.25 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:when I switch from english to hebrewand other way around it doesn't work

Solution:within the database table wp_options your 'home' field had the URL added with 2 extra spaces thus the %20 in the URL

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by reutS 6 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
April 5, 2019 at 4:07 pm #3545651

reutS

I am trying to:
switch from hebrew to english and the other way around
Link to a page where the issue can be seen:
hidden link
I expected to see:
hidden link
or
hidden link
Instead, I got:
hidden link .

. hidden link

April 5, 2019 at 9:08 pm #3547055

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

this is most likely happening due to the %20 within your URL (this stands there usually for an empty space)

if you paste both urls in your browser and replace the %20 they will work as expected

example:

hidden link .

. hidden link

change them to

hidden link .

. hidden link

If possible please go to WP->Settings->General and share with me a screenshot of your

WordPress Address (URL) and Site Address (URL) , also make sure that there is no added space within the URL name.

additionally if you have access within your database verify the same within wp_options table, these are the first 2 entries usually in wp_options.

April 6, 2019 at 4:26 pm #3549593

reutS

I can't change the url since they appear in the correct form (they are permalinks so I can't change them) I attached a screenshot now of the home page in my WordPress and what you asked for. Thanks.

April 8, 2019 at 5:04 pm #3560317

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

This could be happening due to a 3rd party plugin adding this space into your URL structure.

If possible i would like to take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

April 10, 2019 at 8:42 pm #3581307

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The issue should be resolve now

within the database table wp_options your 'home' field had the URL added with 2 extra spaces thus the %20 in the URL

April 14, 2019 at 8:44 am #3607249

reutS

My issue is resolved now. Thank you!