This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.70 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by geyaA 1 week ago.

Assigned support staff: Bobby.

Author Posts
October 9, 2019 at 9:27 pm

geyaA

I am trying to: Translate a page

Link to a page where the issue can be seen: hidden link

I expected to see: Not blank one

Instead, I got: blank one

October 9, 2019 at 10:35 pm #4725813

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Please go to Pages->Edit default language page->Use the language switcher in the top header and switch to the second language

While in the second language now review your page builder, you will notice that some elements are missing, please update it and let me know your results.

In this situation I believe "duplicating" the page would have been a better option in order to keep your layout the same and then adding your translation.

Also as this page has media please go to WPML->Settings->scroll to the bottom of the page and run the WPML Media actions.

October 9, 2019 at 11:02 pm #4725835

geyaA

Hi, it is exactly what I did, I chose "Copy content from Български" meaning "Copy content from Bulgarian". And you can see the result here:
hidden link

It is an empty page, where I tried to add my portfolio, but it does not work (it is empty).

You can check it in the original language where everything is OK: hidden link

When you write "WPML Media actions" I believe you mean "Media Translation"? Yes, I did it. No changes.

October 10, 2019 at 3:04 am #4726819

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for updating me.

This might be happening because your portfolio items are not translated.

Please go to Portfolio and add the translations to your portfolio items and let me know if that resolves the issue.

October 10, 2019 at 8:47 am #4728491

geyaA

Hi, when I try to translate Portfolio, I have similar issue:

I try to translate this portfolio item:
hidden link
I press the button "Copy content from Български" meaning "Copy content from Bulgarian"
But nothing happens, and it keeps showing me empty portfolio page in English.

When I try to preview the English version of the page it is totally broken: hidden link

October 10, 2019 at 10:06 pm #4734333

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

I went to WPML->Settings->Media Translation and run it again scanning all your media.

Then I went to Portfolio and delete the translation you added.

Afterwards I did the following steps:

1. Go to Portfolio->edit the default language page
2. Check the box to "duplicate" and duplicate into the secondary language
3. Refresh the page and then use the top header language switcher to go the English version, dismiss the warning and continue
4. Verify that it was duplicated correct and add any translations necessary.

-> hidden link

October 11, 2019 at 8:16 am #4736331

geyaA

My issue is resolved now. Thank you!