This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 7 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 21, 2019 at 4:20 pm

francescoE-2

I am trying to: edit every products

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: Hi, I try to editing same product but I have this error message:

The recommended way to translate WooCommerce products is using the WooCommerce Multilingual products translation page. Please use this page only for translating elements that are not available in the WooCommerce Multilingual products translation table.

February 21, 2019 at 9:04 pm #3230047

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It happens because you are using the WooCommerce Multilingual addon, when doing so, the prefered method of editing your translated products attributes, categories, etc is using the WooCommerce Multilingual itself, it offers a unified interface where you can translated every content related to your products, you can learn more about that at: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

February 22, 2019 at 9:52 am #3231650

francescoE-2

Hi, thanks for your assistente,
in: WooCommerce Multilingual > Status
I read this:
Alcune impostazioni contenute nel file wpml-config.xml di WooCommerce Multilingual sono state sovrascritte.
You should check WPML configuration files added by other plugins or manual settings on the Multilingual Content Setup section.

La configurazione del campo personalizzato _stock del file wpml-config.xml è stata alterata!

Can you help me to understand what I do to resolve?

February 22, 2019 at 8:06 pm #3233874

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding the status message, it seems either your theme or some of your plugins is providing a custom wpml-confing.xml file that overwrites the standard settings for WooCommerce.

Please review all wpml-config.xml files in your theme and plugin folders (you can find them in the root theme and plugin folders) to check which one is overwriting the settings. When you find it, please remove these settings from the files (besides WPML and its add-ons files).

You can also disable your plugins and activate one by one in order to identify which one is overwriting these standard settings. You can read more about language configuration files at https://wpml.org/documentation/support/language-configuration-files/.

Please, let me know if it helps and if you need any additional clarifications, have a nice day.

February 25, 2019 at 10:24 am #3239004

francescoE-2

Hi,
can you enter in my site end try to resolve the problem?
I read this: We detected a problem in your WPML configuration: the product_type taxonomy is set as translatable and this would cause problems with translated products. You can fix this in the Multilingual Content Setup page.
please help me to resolve the problem, thanks a lot!

February 25, 2019 at 6:22 pm #3241588

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look in your WordPress Dashboard and couldn't notice any issue, also I see the product_type taxonomy is already setup as non translatable from your WordPress Dashboard > WPML > Settings options which made the notice message gone. Do you still need any assistance from our side? Please, let me know, have a nice day.

February 26, 2019 at 9:15 am #3243654

francescoE-2

Hi Marcos,
thanks a lot for your support. Now I resolve the issue of product_type taxonomy but I have a new problem. The product have the padlock in a price quantity etc, and I must disconnect everyone and reconnect with the same en version.
Can this be solved? is there a way to do it automatically, without me intervening on the single product?
I am attaching a screen to show you better what I mean

February 26, 2019 at 3:45 pm #3245818

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It happens because you are trying to edit the price and quantity of your translated product, note you don't need to change it in your product translation as these fields are synchronized from the original product, if you need to keep different prices for different currencies for example, you can try the multiple currencies feature of the WooCommerce Multilingual addon from: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#multiple-currencies. Please, let me know if you need any additional clarifications, have a nice day.

February 27, 2019 at 11:10 am #3249726

francescoE-2

Hi Marcos,
I think I did not explain well. I try again, I have a site in two languages (ita & en) the Italian language is the main one. I created the product in Italian and duplicated in English at a later time. Now when I try to change the product in Italian it comes out with padlocks. Same thing happens if I try to change the one in English.
I understand that the one in English (being secondary language) inherits price and other characteristics from the Italian product and therefore does not allow the modification of some fields, but I do not understand why even the Italian one is completely blocked. And only by dissociating the product from the two translations the solution is restored.
Can you explain to me why this happens? You have access to the site, if you want to enter to check or make changes to the WPML settings you are welcome!

February 27, 2019 at 8:50 pm #3252518

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website and couldn't notice the same issue in other products, in your particular case, it seems you created the product in english (secondary language) then duplicated it to italian (primary language) as the attached image suggest. Doing so, you make your product attribute locked for editing in the original language as WPML would interpret italian as you translation instead the default langiage which you always should create your products.

You are still able to change the product default language when using the WooCommerce Multilingual editing interface. Please, let me know if I am missing any concept here and if you need some more clarifications from our side, have a nice day.