This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 17 replies, has 3 voices.

Last updated by Alejandro 4 months ago.

Assigned support staff: Alejandro.

Author Posts
May 27, 2019 at 10:32 am #3895967

mehmetC-5

I am trying to: view all listings in another language than English

Link to a page where the issue can be seen: homepage

I expected to see: all my listings page in Turkish

Instead, I got: all my listings page in English

on 13-29-37.png I click on the 'Tümünü Görüntüle' button. Then the other page appears in English.

May 27, 2019 at 4:47 pm #3899675

mehmetC-5

In addition to problem above I mentioned, as you can see in the first and second photos, the tags on cards look different in different languages.

May 27, 2019 at 6:51 pm #3900343

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me the following:
- are Listings set to this?
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/#displaying-original-taxonomy-values
- or is the problem that in whichever language you click "View all", you go the same URL?
-- if this is the issue, can you check this answer and the thread in a whole and try what we suggested here?
https://wpml.org/forums/topic/error-404-and-search-not-working-on-translated-content-with-template-rea/#post-3542827

Regards,
Bruno Kos

May 27, 2019 at 11:30 pm #3901275

mehmetC-5

Hello, I am adding the photos of listing settings.

The problem is that you mentioned in the second case. Whichever language I click "View all", I go the different urls which includes language parameter but page shows up in English always and when I click on another language from switcher it just directs me to homepage.

The solution link you offered is not applicable for my case since I use a different theme and there is no additional page for results.

May 28, 2019 at 12:06 am #3901471

mehmetC-5

Also, if you need to check my website by yourself, I can send login information.

May 28, 2019 at 9:27 am #3904675

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

The problem is that you mentioned in the second case. Whichever language I click "View all", I go the different urls which includes language parameter but page shows up in English always and when I click on another language from switcher it just directs me to homepage.

I wasn't able to find any similar case in our archives so far (so this will need to be escalated to our compatibilty team most likely), but I checked the theme official site and found this, someone posted it:

""""""""""""""""""""""""""""""""""""
Hi Contempo, join here the solution to get the right slug for featured listing in link ”View all” for all lang

in /include/featured-listing.php on line :29 replace : <?php if(is_plugin_active(‘sitepress-multilingual-cms/sitepress.php’)) { ?> by : <?php if(!is_plugin_active(‘sitepress-multilingual-cms/sitepress.php’)) { ?>

(look to desactivate the multilang operator)

and now the solution ! with WPML

on line : 33 after the <?php } else { ?> replace with this code <?php esc_html_e(’View All’,’contempo’); ?>

this code include to integrate a new variable in WPML String and now you have to translate on any lang your slug
""""""""""""""""""""""""""""""""""""

This seems to be this exact thread if I am not mistaken:
https://wpml.org/forums/topic/translation-management-issue-with-wp-pro-real-estate-7/

From what I see, they were fixing several issues on that ticket and I think that one of these is also what somebody suggested here:
hidden link

Can you go through these links thoroughly and check what they suggested there, especially on what linked WPML support ticket?

Regards,
Bruno Kos

May 28, 2019 at 11:49 am #3906421

mehmetC-5

Hello, I went over all the links. One solution is half-worked.

https://wpml.org/forums/topic/translation-management-issue-with-wp-pro-real-estate-7/

A solution in this link worked for 'View All' button. I am adding the picture of one worked.
However, after the view all page opened when I click to change to another language it still directs me to homepage directly.

In addition, I still have the same problem with the search box. When I search, the results are always in English.

May 28, 2019 at 1:31 pm #3907517

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

However, after the view all page opened when I click to change to another language it still directs me to homepage directly.

If I do this from the English page and try to switch the language, I can also get redirected to home page only. I assume that there is no other template that would control this page, meaning, when you are on this search page, you can't edit this page and possibly translate it, but it is being generated dynamically?

Regards,
Bruno Kos

May 28, 2019 at 2:32 pm #3907897

mehmetC-5

Yes, it is being generated dynamically. Also what about the search problem? Any idea on it?

May 28, 2019 at 5:22 pm #3909003

mehmetC-5

Hello,

1.Regarding the problem that on homepage there is a search box and results of search box always comes in English.

When I worked a little bit on the problem I got a point that might help to solve the problem of search box.When search is clicked url is seen as this on when results appear.
hidden link
So this url doesn't have any language parameter. When I manually add language parameter and change url to
hidden link
the results of search appears in the translated language.
So the problem is that search box is not adding the language to query its results.
Any idea on solving this?

May 30, 2019 at 2:54 pm #3924003

mehmetC-5

Is there any progress on solution? I still have the problem.

May 31, 2019 at 9:33 am #3929121

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Alejandro.

Since Bruno currently has a few days off, I will replace him here in the forum.
I hope this is OK with you.

Yes, it seems that both the search box and the listings map page are not working as expected, because they might not me compatible anymore.

I suggest that you try to replicate the problem in here: hidden link

you need to basically install the theme and the theme's plugin that make the listing appear.

create 2-3 listings with dummy content and translate it in different languages.

Follow the instructions on this page hidden link to configure the theme and make it compatible with WPML.

the problem is most likely going to be replicated in there as well, because it seems they removed the filters that made that page compatible with us.

At the same time it would be good if you could create awareness of this issue creating a ticket on their support, that way we can get both our devs and theirs working for a more permanent solution.

I'll do my best to find you a workaround in the meantime.

Regards.

May 31, 2019 at 12:48 pm #3930531

mehmetC-5

Hello,
I am totally fine with your replacement.

I replicated the problem on sandbox. I activated the theme, created listings and the problem appears again.

May 31, 2019 at 3:56 pm #3931893

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Perfect. i'll go check it out and send it to our dev theme while i try to find a workaround for you!

In the meantime, can you please tell me what steps did you take to replicate the problem on the sandbox site, please?

this will help me speed the process up while sending the case to our development team.

Regards.

May 31, 2019 at 6:31 pm #3932685

mehmetC-5

I uploaded the theme and created my homepage then added listings then configured WPML.
After configuring WPML I created the translated page and listing. Then I am able to see the translated homepage including listing. Then just tried the 'search' and 'view all' buttons. Then problem appears again.