This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by guilhermes-9 5 months ago.

Assigned support staff: Andreas W..

Author Posts
May 15, 2019 at 5:25 pm #3819043

guilhermes-9

I am trying to: generate a duplicated version of a post in brazilian portuguese to show in portuguese from portugal

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
hidden link
hidden link

Instead, I got: the duplicate version in portuguese from portugal its triplicating the content, but when i access the post page to edit it only show the correct amount of text, its not triplicated at all, and its not generating the canonical link pointing to the original post (in brazilian portuguese) as well. I have already duplicated another page (it wasnt a post) and it worked correctly, is this one below, it has even created the canonical correctly that points to the brazilian portuguese version:
hidden link

May 15, 2019 at 11:18 pm #3820475

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML support.

The weird thing here is that some posts are affected and others not. Do I understand right that this onlz occurs after duplicating and not after a translation?

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 16, 2019 at 3:26 pm #3827459

guilhermes-9

Hello Andreas thanks for the reply,

Actually its happening in all duplicated and translated posts, the only time it does not happen its on the original post in brazilian portuguese, i will upload an image of the screen from a page where i selected to translate another post (a third one), the problem is that not all of the text is showing to translate, only parts of the original post, so it seems that this problem is only occuring in posts, when its pages and products from woocommerce it works fine...

i will upload the image from the translation page and the final URL would be the one below, where you can see the same error happening again
hidden link

right now i cant run the website in minimal configurations due to my users traffic, could you please create a sandbox enviroment so i could test it there without affecting my online website?
so i could test it thoroughly removing plugins and themes 🙂

May 16, 2019 at 4:00 pm #3827755

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 16, 2019 at 10:56 pm #3829811

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The provided FTP access sadlz leads to an empty folder.

WordPress includes a debug mode which helps reveal PHP problems.

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );
In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );
The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */
Please note that you’ll see everything, not only related to WPML. This will most likely include messages from other plugins, your theme and sometimes even WordPress core. The messages appear all over the place. Sometimes they appear right on top, but they can also appear in the middle of the page.

Further, please try to run the site with WPML and WPBakery only for testing if the translation works in minimal setup. Simply deactivate each plugin that is not necessary to visualze the post. Then give the original post a small update and translate it again. Is the content still appearing duplicated?

Kind regards
Andreas

May 16, 2019 at 11:52 pm #3829837

guilhermes-9

Hello andreas and thanks for the reply,

im really sorry about the empty file, i talked to my hosting company and now they fixed the path problem, now its showing all the files of the website correctly.
I think i didnt quite understand the steps you described to me, unfortunately it goes beyond my knowledge :/

And again, thanks for your time and support.

Best regards.

May 17, 2019 at 9:53 pm #3837087

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have searched in within our older tickets an there been issues with content duplications usign Uncode.

The workaround here was to translate the Unicode Content Blocks. I tried to translate the Content Blocks that refer to the Blog and translated the content again but it did not solve the issue.

I would kindly like to ask you to translate all the available content blocks and let me know if the issue persists?

In the meantime I installed a test site and it would be helpful if you could install the latest version of Uncode here for further testing:

One Click Login: hidden link

Please leave me short a notificationonce the theme is installed and try translating all the Content Blocks.

Kind regards
Andreas

May 18, 2019 at 12:22 am #3837373

guilhermes-9

My issue is resolved now. Thank you!