This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
When translating homepage, I get stuck on "saving the page", after that I get 503 error. How to fix it?

Solution:
I checked theme/plugin conflict in your site. I enabled error reporting at your site and examine debug.log file inside /wp-content folder. I can see following error in debug.log file:

[08-Oct-2018 14:07:39 UTC]  .../custom_modules/cfsm.php:11  Custom_ET_Builder_Module_Search::init():
Custom_ET_Builder_Module_Search::$whitelisted_fields is deprecated.

[08-Oct-2018 14:07:39 UTC]  .../custom_modules/cfsm.php:36  Custom_ET_Builder_Module_Search::init():
Custom_ET_Builder_Module_Search::$advanced_options is deprecated. Use Custom_ET_Builder_Module_Search::$advanced_fields instead.

[08-Oct-2018 14:07:39 UTC]  .../custom_modules/cfsm.php:78  Custom_ET_Builder_Module_Search::init():
Custom_ET_Builder_Module_Search::$custom_css_options is deprecated. Use Custom_ET_Builder_Module_Search::$custom_css_fields instead.

But when I activate Divi parent theme all errors goes away from debug.log file and I can update homepage translation successfully without that issue.

Now, please try to activate Divi parent theme and translate home page. As I can see issue is probably occurring due to Divi Child theme.

Relevant Documentation:
https://wpml.org/documentation/support/debugging-wpml/

This topic contains 7 replies, has 2 voices.

Last updated by williamA-13 1 year ago.

Assigned support staff: Noman.

Author Posts
October 2, 2018 at 11:50 am

williamA-13

When translating homepage, i get stuck on"saving", then i get the 503 error. Which downs my whole site for 10 minutes, please what is the issue that is causing this to happen.

October 4, 2018 at 8:14 am #2786643

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have logged in to your site and opened home page in Nederlands and clicked on “+” icon to add translation in English language. Then I pressed “Copy all fields from original” button and selected all checkboxes to make translation 100% complete and hit “save and close” button. Now I can see translated homepage without any issue. Could you please clear your site cache and take another look on it. If still issue persists, Could you please let me know the steps that causing 503 issue.

Thank you

October 4, 2018 at 5:58 pm #2788496

williamA-13

I tested: So I open home, translate a section, click on save. But then saving is stuck. This is the message:

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.4.29 (Unix) mod_hive/6.6 OpenSSL/1.0.1e-fips mod_fastcgi/2.4.6 Server at hidden link Port 443

October 5, 2018 at 8:02 am #2789812

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please check for a possible theme and plugin conflict. To do that you need to backup your site and switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If issue still persists, please provide temporary access (WP-Admin) to your site, so that I can look into your setup and debug the issue.

=== Please backup your database and website ===

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 5, 2018 at 10:17 am
October 5, 2018 at 4:38 pm #2791333

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

I logged-in to your site and tried to reproduce the error in your site. At first I was not able to see the error and page saved fine. But after sometime when I tested again, I am able to see the issue in your site.

I am still working on it and it will take some time to investigate further. I will be checking for plugin and theme conflicts or any other issue that I see and I will let you know about my findings.

Thanks

October 8, 2018 at 4:32 pm #2796936

williamA-13

Hello, i am seeing weird activities on my website letzparty.nl please let me know it is you, and can those changes/detecting be done during night time on Netherlands (GMT+2).
Please let me know asap because this site is a webshop i cannot have downtime during daylight.

October 8, 2018 at 6:41 pm #2797100

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

Yes, I was checking theme/plugin conflict in your site. I enabled error reporting at your site and examine debug.log file inside /wp-content folder. I can see following error in debug.log file:

[08-Oct-2018 14:07:39 UTC]  .../custom_modules/cfsm.php:11  Custom_ET_Builder_Module_Search::init():
Custom_ET_Builder_Module_Search::$whitelisted_fields is deprecated.

[08-Oct-2018 14:07:39 UTC]  .../custom_modules/cfsm.php:36  Custom_ET_Builder_Module_Search::init():
Custom_ET_Builder_Module_Search::$advanced_options is deprecated. Use Custom_ET_Builder_Module_Search::$advanced_fields instead.

[08-Oct-2018 14:07:39 UTC]  .../custom_modules/cfsm.php:78  Custom_ET_Builder_Module_Search::init():
Custom_ET_Builder_Module_Search::$custom_css_options is deprecated. Use Custom_ET_Builder_Module_Search::$custom_css_fields instead.

But when I activate Divi parent theme all errors goes away from debug.log file and I can update homepage translation successfully without that issue.

Now, I have again enabled Divi child theme in your site and turn off error reporting. Could you please try to activate Divi parent theme and translate home page and let me know the results. As I can see issue is probably occurring due to Child theme.

Thank you

October 9, 2018 at 6:40 am #2798380

williamA-13

My issue is resolved now. Thank you!