This thread is resolved. Here is a description of the problem and solution.

Problem: When translating pages, the URL gets translated as well. Solution: By default, the post slug is generated automatically based on the title. To change this setting, navigate to WPML > Settings > Translated documents options > Page URL and select Translate & click on save.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by denisD-13 6 months, 2 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
November 8, 2019 at 7:53 pm #4916531

denisD-13

When translating one of our pages to French, the URL is being changed as well. For example if the URL is devds.deadhaussonata.com/store it will be changed to devds.deadhaussonata.com/magasin.

We want to prevent this from happening since there is code that depends on the route of the URL.

November 9, 2019 at 12:05 pm #4917987

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

By default, the post slug is generated automatically based on the title.
If you want to change this setting, you can navigate to WPML > Settings > Translated documents options > Page URL and select Translate & click on save(See attached screenshot)

If you have any doubts, please let me know.

Thanks,
Rohan

November 12, 2019 at 2:40 pm #4932531

denisD-13

My issue is resolved now. Thank you!