Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bruno 11 months ago.

Assigned support staff: Bruno.

Author Posts
March 23, 2020 at 2:48 pm #5742603

Ido Fishman

Tell us what you are trying to do?
trying to update Hebrew page and its override English page
trying to update English page and its override Hebrew page

March 24, 2020 at 12:53 am #5746669

Bruno

Thank you for contacting us. Is this happening on every page, including new pages?

Also, have you duplicated these pages previously? If you have duplicated these pages, please follow the steps in our documentation for you to translate these pages independently: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/#convert-between-translation-and-duplicate

Following the steps above, does the problem still persist?

Thank you.

March 24, 2020 at 7:08 am #5748051

Ido Fishman

1. Is this happening on every page, including new pages? yes
2. have you duplicated these pages previously? no, we used right boc of translate in the page (before months ago) and this issue is happen after WPML plugin update
3. the issue with the custom feilds, we are using acf pro with WPML support

March 25, 2020 at 7:46 am #5757675

Ido Fishman

any one!

March 25, 2020 at 4:43 pm #5762783

Bruno

Sorry for the delay. So that I can test your site, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

March 27, 2020 at 10:08 pm #5782947

Bruno

Unfortunately, I could not understand the problem you are reporting.

About the message that is displayed at the top, it is just an alert. The content, however, is not overwritten with the content that is in Hebrew. That is, the only message that is displayed is an alert, but no content is being overwritten.

Please, could you elaborate a little more? In your first message, you say:


trying to update Hebrew page and its override English page
trying to update English page and its override Hebrew page

How do I replicate this?

Thank you.

March 30, 2020 at 12:30 pm #5794555

Ido Fishman

Hi,
let me explain:
initially once we updated text in one language its overwritten the other.
then we deleted all symbols one by one in costume fields and it worked well - no overwritten and no symbols.
today - the issue is back BUT with the following behavior: the content is not overwritten when updating one language but all the symbols are back everywhere in the site!!

i would appreciate a prompt response to solve this.

thank you

March 30, 2020 at 4:58 pm #5797463

Bruno

Thank you for the explication. This is happening because even though you initially attempted to duplicate or copy the fields of the ACF, after changing them, it is necessary to change the options also in other languages.

This message is about: Please review WPML translation preferences for this field before saving field group! Otherwise, default value (Don't translate) will be set.

On the Custom Fields > Fields Groups and switch to the Hebrew language, click to edit the "Layout 1". On the "video_section", note the "warning". I will attach an image for you to see.

Any changes made in one language, you must be sure to make in other languages. Changing this to "Translate", the alert disappears. You must be sure to do this within the options of the ACF.

Following these steps, does the problem persist?

Thank you.