This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 9.69 hours from now. Thank you for your understanding.

This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 5 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
April 10, 2019 at 7:29 am #3573101

hooiC

I am trying to: when W2TC cache was turned on, it has messed up the styling and the secondary language not displaying on the language switcher on the default language (English) site. we have turned off the W3TC cache now and these issues now resolved.
We configured the W3TC in accordance with https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/
what can we do to w3tc so we can activate it again on live site . currently our live site is very slow.

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

April 10, 2019 at 9:22 am #3574153

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you tried disabling some options within the plugin? E.g. this option:
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/#css-and-javascript-js-minification

I've seen very often in practice that JavaScript minification tends to break layouts and options. If I may suggest that you try various options to see if there's a particular option that broke the layout, while keeping others active.

Regards,
Bruno Kos

The topic ‘[Closed] when W3TC cache was turned on it messed up the styling and language switcher’ is closed to new replies.