Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: My website redirects to the http: protocol (instead of https)

Solution: Please try the following: - Install and active this plugin: https://wordpress.org/plugins/really-simple-ssl/ - Go to Settings > Permalinks - Re-save the permalink structure

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by philipped-14 1 year, 6 months ago.

Assigned support staff: Diego Pereira.

Author Posts
February 27, 2019 at 8:30 pm #3252475

philipped-14

I am trying to: use NL pages in our Web site.

Link to a page where the issue can be seen:hidden link

I expected to see:hidden link

Instead, I got:hidden link and the default page hidden link is shown

February 28, 2019 at 6:20 pm #3257020

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @philipped-14, welcome to the WPML support Forum!

Not sure if I understood correctly. You translated the page but it redirects to the homepage of your website? Could you send us more details?

Please also check the following:
- Go to WPML > languages > Hidden languages and check if thelanugage is set as "Hidden"
- Go to the translation editor and check if the translation is with the status 100% complete

Please also check the status of the translated page:
- Go to the edit screen of the page (original language).
- Change the language using the Language switcher at the top admin bar
- if it display a warning, click on "Edit Anyway"
- Check if the page is published

Please let me know if it worked for you.

All the best,
Diego

March 1, 2019 at 7:52 am #3258768

philipped-14

Hello Diego,

Not exactly, our translated pages are redirected automatically from for example hidden link to hidden link
and because this page doesn’t exists, we come back to the default page hidden link
It’s the same for all our translated pages.
If we use directly the url, it works well.

To response to your others requests :

The language value is not hidden. See in attachment.

I make the verification if the translation are published.
You can see in the attachment "Page Groupes NL" the page is published.
You can also the correct URL hidden link replaced by the wrong URL with http hidden link. And I don't know why and how I can ovoid this process.

Thanks a lot in advance for your support
Best regard,

March 1, 2019 at 3:28 pm #3261902

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

So it redirects to the http protocol (instead of https), correct? In this case, please try the following:
- Install and active this plugin: https://wordpress.org/plugins/really-simple-ssl/
- Go to Settings > Permalinks
- Re-save the permalink structure

Please let me know if it worked for you.

Kind regards,
Diego

March 1, 2019 at 10:04 pm #3263276

philipped-14

My issue is resolved now. Thank you!