This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
March 20, 2019 at 11:50 pm

filipposH

I though this was a jupiter x / elementor issue but it seems there is a conflict with wpml!

See this link I posted in artbees forums regarding the history of my issue:hidden link

It all started when the wp_options table in my database got so big that wordpress crashed on load (frontend gave me error 500 and whenever I tried accessing anything to do with the theme from the backend too)

After I restored a database averytime I hit refresh in fronted the cpu load went crazy at 90%. And the backend when using elementor was really slow. GTMetrix showed full website load time at 18.5 seconds.

Now that I have disabled WPML everything seems normal again. GTMetrix dropeed to 5.6 seconds.

Link to a page where the issue can be seen:hidden link

I have now disabled all these WPML plugins:
WPML Media
WPML Multilingual CMS
WPML String Translation
WPML Translation Management

March 21, 2019 at 9:10 am #3397149

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Your WP Memory limit is really low: hidden link
Could you please increase it as much as you can and check the issue? http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Let me know how it goes.

Regards,
Riffaz.

April 1, 2019 at 6:45 pm
April 1, 2019 at 8:17 pm #3511495

filipposH

I think it has something to do with Jupiter X theme + WPML.
Jupiter X is not that fast compared to my other websites (this is the 1st time I use Jupiter X, last time I used the previous versions of jupiter before the elementor composer but with the wp bakery).
Me CPU load when using this wordpress instance with jupiter X is weird (3%) that shouldn't even be there. I can see the server responding really slow even with caching enabled (autoptimize). BUT nonetheless it is usable. When enabling WPML everythins is X10 slower. I sometimes get tired of waiting for it to load so I do not preview my pages when editing them anymore.
The CPU usages reaches 60%! This time I have not enabled string translation and translation management.

I really want you to look into this cause it drives me nuts!

April 2, 2019 at 3:38 pm
April 2, 2019 at 4:18 pm #3519079

filipposH

Firstly, thank you very much for your actions...
It was just migrated BUT I think something is not right as I cannot see it online in the URL provided (ERROR 500)
hidden link

You go ahead and check it out. At least I am not crazy 😛
Edit: I can see it now, but it is even slower. Thanks again!

P.S. Can you lease delete the domains in my post reply #3510977 as they are public (my bad)

April 3, 2019 at 9:00 am #3523821

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for this.

We are checking this now internally.
Please be patient till we get back to you.

Regards,

April 4, 2019 at 9:45 am #3533663

filipposH

I have a thead in the artbees forum aswell with anotherone responding to the same issue, the Jupiter X and WPML issues. Check here: hidden link

April 4, 2019 at 1:46 pm #3535419

filipposH

Check the reply under the artbees forums. It seems the wp_options is indeed casuing problems. See if that helps you out.

April 7, 2019 at 2:26 pm #3552139

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the forum link.
That could be reason.

To make sure we have to check monitor the query.
The migrated site also produce 500 error/blank screen.
This makes the process slow.

Please install this plugin in your site: hidden link
Share the monitored results with us.

Provide with the results that are showing load time with/without WPML, with/without other plugins but WPML enabled, default theme.

Let me know.

Regards,

April 14, 2019 at 7:20 am #3607105

filipposH

As my website is live, these are tests that unfortunately I cannot take. It is a Jupiter X issue though, as when I used the solution provided in their forums everything came back to normal. I have not tested all the WPML add-ons though, only the main one. But for now, I am ok. Thanks for your support.