This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Bigul 6 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 16, 2019 at 10:30 am #3359813

massimoC-25

I am trying to: create a new page editing by Cornerstone

Link to a page where the issue can be seen: any new page (see image)

I expected to see: Cornerstone edit mode

Instead, I got:error by Cornerstone Editor

Steps to duplicate the issue: add a new page and click edit with cornerstone. You can't edit and you can't get the preview

it doesn't work as long as WPML is active I'm getting the you blew up the internet message

WORKAROUND
1) Dsable WPML plugin
2) Creare a new page by Cornerstone editing. Save it
3) Enable WPML plugin
4) Re-open the page and complete the editing by cornerstone

March 16, 2019 at 5:05 pm #3361041

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of the compatibility issues. Please upgrade the following configuration for the expected performance of your site and check the issue is existing or not.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *5000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

If you are still having the issues, please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

March 20, 2019 at 10:51 am #3387729

massimoC-25

Thnk you for your reply:
I upgrade the configuration as you described in step 1) and step 2).

Here you can find my NEW current PHP config
hidden link

I send to you a new WPML LOG
https://pastebin.com/9Uu3vhsQ

I remeber to you
- all is working if I disable WPML plugin on page creation (erros is present only whena pages are newly created)
- i attach IMAGE for the javascript error i get in browser console

March 20, 2019 at 6:22 pm #3392395

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for updates. The *Debug.log* and Debug information is different. So have you added the following code in *wp-config.php* file?

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
  
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
  
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

X theme and the Cornerstone is compatible with WPML. So I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

March 21, 2019 at 5:08 pm #3413783

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. I can reproduce the issue. But it works for me when I create a new Page, save it from Page Edit screen and then edit using the Cornerstone. Please check the attached images for more details.

It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

March 22, 2019 at 7:07 am #3438009

massimoC-25

Please install DUPPLICATOR as you need and try to solve my problem.
Thank you
massimo

March 22, 2019 at 6:40 pm #3443629

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy and debugging the issue on my local server. The bug is existing in my local copy.

But I have a request. Cornerstone has released a new version 3.5.4. So would like to try with the latest version. Please upgrade to the latest version after a site backup and check the bug is existing or not.

--
Thanks!

Bigul

March 25, 2019 at 7:51 am #3450165

massimoC-25

Hello Bigul,
thank you for your kind assistance.
I updated cornerstore plugin to the last release but the error is still present.
Hope to hear from you soon.
Bye
massimo

March 27, 2019 at 7:16 am #3468157

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Massimo,

For your kind updates, I have escalated the ticket to our second tier team for further debugging. We will get back to you as early as possible. Please wait.

As a workaround, for the time being, please save the page first then edit with Cornerstone.

--
Thanks!

Bigul

April 3, 2019 at 9:26 am #3523975

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Massimo,

For your kind information, the issue is happening because of a mismatch in the query. It happens when WPML, Cornerstone and X theme are active. It returns a wrong post ID and this is why the page loads error 404.

It is working as expected in our local copy after the following steps. Please try it after a full site backup and let me know your feedback.

1) Switch to Twenty Nineteen
2) Replace WordPress core files from Dashboard>>Updates>>Reinstall
3) Remove icl_sitepress_settings key from the options table
4) Re-run WPML setup
5) Try to edit a new page with Cornerstone
6) Switch to the theme X
7) Try to edit a new page with Cornerstone

--
Thanks!

Bigul