This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:When you hit english flag you get to the homepage but dissapears

Solution:Issue was resolved once the translation of the menu was assigned to the default language of the menu.

Translating the menu resolves this issue

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by alessandrob-43 5 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
April 16, 2019 at 11:16 pm #3625919

alessandrob-43

I am trying to: keep the flags allways in all menus (i tried adding the menus i have in the english version but only gives me the menus ive created in the italian.

Link to a page where the issue can be seen: hidden link

I expected to see: the flags once you get into the english language

Instead, I got: that when you hit the flag it dissapears the option to get back to italian.

April 16, 2019 at 11:48 pm #3626047

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

how are you currently adding the flags to your menu ? are you adding them from within WPML->languages->language switcher ?

additionally what are your results if you go to WPML->languages -> add footer language switcer

does this switcher disappear as well ?

April 17, 2019 at 2:03 pm #3631503

alessandrob-43

Thank you very much for your quick answer

Basically i can put them on the italian (main language menus) but not in the english menus there is no option
If you go in the URL you can see what i mean.
You hit the english flag in the homepage (homepage turns to english) but because it has the english version menu it has no flag.

April 17, 2019 at 8:03 pm #3634619

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look, there might be some slight configuration issue

i believe once i link your menus with each other it will work as expected, your menu should be a "translation" of the default language menu

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

April 19, 2019 at 10:43 am #3645027

alessandrob-43

Btw it makes sense what you said about the translation of menu because i made uniques menus for that.

Just check what you wanted to check and let me know if it was only that. and if there a place where I can personally help you I would love to leave a review for you because you are really helping me out.

April 22, 2019 at 5:23 pm #3657429

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The issue should be resolved now

i made the ENG menu right a translation of the Italian main menu and the language switcher is showing as expected

let me know your results please

April 22, 2019 at 9:23 pm #3658379

alessandrob-43

My issue is resolved now. Thank you!