This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 1 month ago.

Assigned support staff: Bigul.

Author Posts
February 20, 2020 at 1:08 pm #5533181

sing-leungT

hi,

my images are hosted on aws s3, but whenever I duplicate my post, the image does not show up. how could this be fixed, please?

February 20, 2020 at 3:24 pm #5534373

sing-leungT

The Media Translation plugin is done with the set-up. I tried to do a duplicate of an item again, and the S3 images are still not duplicated on the items. The images still show up blank.
Please let me know how to fix this.

February 20, 2020 at 4:03 pm #5534831

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

February 21, 2020 at 6:34 am #5537979

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. The Chinese posts are showing the featured image in the backend and frontend of the site. Please check the attached images. Therefore please let me know the exact steps to reproduce the issue on your site.

--
Thanks!

Bigul

February 21, 2020 at 3:46 pm #5542265

sing-leungT

Hi Bigul,

Those are previously there. My issue is more on the newer items/images uploaded.

Please try to translate/duplicate the first item on the Product page. The item's title is: Item 1.

However, I normally use the Translation Management to translate/duplicate the items so I can translate/duplicate in bulk.

Please let me know how it goes.

Thanks

February 21, 2020 at 5:03 pm #5543081

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It was happening because the following options of *Media attachments* were not set for the Product *Item 1*. And also it was not set in WPML>>Settings>>Media Translation>>How to handle media for new content. Please check the attached images.

a) Duplicate uploaded media to translations
b) Duplicate featured image to translations

I have set both now and duplicated the Product to Chinese. It is showing the Product featured image now. Please check - hidden link

--
Thanks!

Bigul