Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bobby 4 years, 12 months ago.

Assigned support staff: Bobby.

Author Posts
November 30, 2016 at 8:49 pm #1148155

robertH-20

I am trying to: view translated pages.

URL of (my) website where problem appears: Cannot provide ; local dev environment.

I expected to see: the page.

Instead, I got: a PHP segfault.

Steps to duplicate the issue: view page.

This is w/ PHP 5.6.25 under MAMP Pro 4.0.5.

Memory limit is very high, libxml and mbstring are installed. This happens on multiple developer machines.

Please advise on next steps for debug.

Thanks.

November 30, 2016 at 10:36 pm #1148267

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

I would need to see the detail of the error. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.wpml.org/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

December 1, 2016 at 2:20 pm #1148957

robertH-20

No PHP errors are logged are created. The only thing that gets logged is an Apache segfault:

[Thu Dec 01 09:17:53 2016] [notice] child pid 80183 exit signal Segmentation fault (11)

December 1, 2016 at 5:09 pm #1149175

robertH-20

This is being caused by the WPML String Translation module, which I unfortunately need because the site uses Gravity Forms and we have other strings that need to be translated.

December 1, 2016 at 6:00 pm #1149224

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for checking for the PHP errors !

From my understanding this is caused by a memory violation.

For that purpose, could you increase your TimeLimit and your memory?

Please go to wp-config.php and let me know what is your current WP_Memory_Limit

https://wpml.org/home/minimum-requirements/

=> To see the WP memory limit you have to login using your FTP and going into the
wp-config.php file , and it will be at the very top.
The Documentation i attached for you goes over details the requirements.

Kind Regards,
Bobby

December 1, 2016 at 7:24 pm #1149296

robertH-20

Memory limit is set to 512M. Time limit is 180 second, and the error is generated way before then. Not getting the normal error when PHP or WP hits its memory limit, just a 500 errror with a segfault listed in the logs.

December 1, 2016 at 8:26 pm #1149338

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

What is your currently PHP memory limit ? is that raised to 512M too? if not please do so.

If it is and the issue still persists if possible i would like to take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

December 1, 2016 at 10:07 pm #1149405

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Yes please feel free to share the snapshot, i have enabled the private field

December 2, 2016 at 5:33 pm #1150342

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

This shouldn't be a problem.

Before proceeding may i kindly ask you to please check this solution provided here and let me know if that helped.

hidden link

December 2, 2016 at 6:02 pm #1150364

robertH-20

That wasn't my problem. I have tested this under several different MAMP environments and an Ubuntu 16 one, and all get the same segfault w/o any real error message.

December 2, 2016 at 6:24 pm #1150387

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I have sent your document over to your email and also enabeld the private filed box

Thank you,
Bobby

December 5, 2016 at 9:49 pm #1152023

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for the additional information,

I escalated this thread to our 2nd tier support and they will take a look at this issue.

You will be notified as soon as new information is available.

Thank you,
Bobby

December 9, 2016 at 6:28 pm #1156387

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi,

We are currently testing this but it seems that the issue is stemming from this plugin,
Plugin Name: Custom Permalinks
Plugin URI: https://wordpress.org/plugins/custom-permalinks/

The topic ‘[Closed] Whenever I visit a translated page, PHP segfaults.’ is closed to new replies.