Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Alex Paulsen 4 years, 3 months ago.

Assigned support staff: Joanna.

Author Posts
August 23, 2017 at 8:22 am #1348934

Alex Paulsen

Hello support, could you please help me understand WPML a little better? 🙂

I've not used WPML for a while now, and it seems to me like a lot of things have changed since 2015. I am currently translating 100 product pages into two other languages, and the new methods has me puzzled.

If I use Translation Management to bulk duplicate the product pages, I can't figure out where to manage them afterwards. They appear in the WooCommerce product directory of the language, but when i click 'edit' to open them, a bunch of tabs show up - but I just wanted to see and translate the text on the product page...How do I do that?

If I instead go to the default language product page and hit the '+' to translate, I go through the quick and simple translation proces. But when I save it, the translation is nowhere to be found afterwards. I can see it is made by the icon, but I can't figure out where to see/edit the translated product page. What makes it more confusing to me, is that with this method, the translated product pages don't show up in the WooCommerce product directory of the other languages.

Could you please guide me in the right direction? Thanks

Best regards,


August 23, 2017 at 11:26 am #1349096


Hello Alex,

You are correct, we made a lot of changes since 2015. One of the most visible changes is introducing Translation Editor that is a recommended way of translating products.

You can find all your products and their translations in WooCommerce->WooCommerce Multilingual->Products tab.

You may read more about translating your products at You'll also find there some screenshots that should

If the product is a duplicate when you open the translation for editing you have the option to translate independently the product.
You also need to remember to mark the translation as completed to be able to see it on the frontend.

Please read the aforementioned documentation page and let me know if you still have any questions or doubts.

Additional documentation:

August 27, 2017 at 6:12 pm #1351823

Alex Paulsen

Hello Joanna,

Thank you very much for the instructions. I've now had a little time to get to know WPML again, and I've hit some bumps along the way, that I need some assistance to solve:

1: When I enter the edit-screen of one of the translated pages, fx. the homepage, I see a message above the editor: "You are trying to edit a translation using the standard WordPress editor but your site is configured to use the WPML Translation Editor.” I know what this means, but what difference does it make, where I translate the page? Seems to me to work the same either way. Is the message indicating a consequence of some kind, that I am not aware of?

2: WooCommerce: When I translate a product or a product category in WooCommerce, the paths to them from the backend are wrong. If I click to "preview" a product or a product category form the backend, I get a 404. But everything works fine in the frontend, here the paths are correct and working. What I am missing in the backend?

3: Possible performance issue/bug: When I translate a product in the Translation Editor, I can't always complete the save. After clicking save, the saving-indicator just spins without finishing, forcing me to go back and do it all over again. This happens about 50% of the time. Additionally, sometimes when saving, the title and the slug of the translated product is gone, in which case the product category name is inserted instead, creating bad URL's and 404's.

4. Is there a way for me to have the same page editing possibilities on a translated product, as when I created it in the default language? My product pages in the default language each have pdf-files attached to them, which is managed by the plugin Download Attachments, and is setup for each product on their backend edit page. I can't find a way to do the same on the translated products, since I only have the Translation Editor's textfields available when translating them. I'm thinking of a way to insert pdf's with shortcodes in the text editor instead, but it will be quite a hassle. Is there a better way?

5. When I visit WPML -> Translations, a message says: ' No translation languages configured for this user.' What does this message mean? I have translated a few products, categories and pages, so I don't understand what this message means.

I appreciate your support on these questions and issues. 🙂

Best regards,


August 29, 2017 at 11:12 am #1353251


Hello Alex,

Normally we only deal with one issue per ticket. I will try to help you with some tips for all of these issues initially in this ticket. However, if more than one issue requires further attention, I may ask you to open another ticket so that issue can get dedicated attention.

1. If you choose to edit your pages using Translation Editor but you use the native WordPress editor, there might be some issues with copying your custom fields, etc. However, those issues shouldn't happen in 99.99% cases. Only some corner cases may cause unexpected issues.
If you prefer the native WordPress editor, you can always switch to the native WordPress editor in WPML settings, in WPML->Translation Management->Multilingual Content Setup->How to translate posts and pages.

2. What is the difference between the URLs? Does the issue occur before you save the translation, i.e. mark it as 100% completed, or before?
It's possible that it's just a cache issue. Please go to Settings->Permalinks and re-save your settings. Also, clear any site and server cache, if you have any. Then, check if the backend URLs are still incorrect.

3. What is the memory limit that you have set on your site? You can check it in e.g. WPML->Support->debug information (link at the bottom). In the debug information search for "WP Memory Limit" and "Memory Limit". They both should be set to at least 128M that is a minimal WPML requirement.
If Memory Limit is less than 128M, you need to contact your hosting provider to increase the PHP limit.
If WP Memory Limit is less than 128M (by default, it's only 40M), you need to increase your WP Memory Limit by adding the following code to your wp-config.php file:

define( 'WP_MEMORY_LIMIT', '128M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

You may want to set different limits but remember to have it at at least 128M.

All WPML minimum requirements are listed at

4. Although Translation Editor is a recommended way to translate your products, you can switch to the native WooCommerce editor at WooCommerce->WooCommerce Multilingual->Settings->Product Translation Interface.

However, did I understood you correctly that you don't have the custom field with the pdf file available in Translation Editor? If so, it's possible that it's set to "Do Nothing" or "Copy" instead of "Translate". You can change the setting in WPML->Translation Management->Multilingual Content Setup->
You should also find the settings on the product edit page (in the original language) at the bottom of the page in the "Multilingual Content Setup" section.
If you change the settings, you may need to re-save the product in the original language to populate settings.

5. As an administrator, you can translate your content manually without being a translator. However, since you are a user of the site, you would be able to translate your content via Translator Interface. For this, you'd need to define yourself as a translator and send the documents to translation via Translation Management module.
You may ask why would you want to do that? You may want to do that e.g. if you prefer to export your content as XLIFF files and translate it in the external editor.
You may read more about setting up translators and using the Translation Management module at

August 29, 2017 at 12:34 pm #1353318

Alex Paulsen


Thanks for the reply. 🙂 I've attached the debugging info, and only issue 2 (and maybe 4) remains open.

Great, thanks. I'll take my chances with the native editor, then. 🙂

Well, in the backend, the url when clicking preview is leads to this: "hidden link"

However, when using the breadcrumb-navigation on the frontend, it links correctly to this:
"hidden link"

I see the error in the path from the backend, that the name of the product-category remains Danish when clicking the 'preview'. But I don't know where to correct it. My product permalink settings are currently set to standard, and underneath it is a language selector and a Translations-link. Should the path be translated from here? I also see something in the Multilingual Content Setup > Custom Posts?

As far as I can tell from the debugging info, my memory limit is at 512. I'll be contacting my hosting provider to confirm this.

Yes, you understood me correctly. The field for adding pdf's to the translated products is gone in the Translator Editor, and it's not on the default product page under Multilingual Content Setup either. Maybe the plugin is not compatible?

Anyway, I think I'll go with your first tip and switch back to the native WooCommerce Editor. That should solve it.

Okay, thanks for explaining, I'll look in to it if necessary. 🙂

Thanks again, I gather you went a long way to help, and I appreciate it.


August 30, 2017 at 2:57 pm #1354440


Hello Alex,

Thank you for the debug information.

2. Please check if:
a) In WPML->Translation Management->Multilingual Content Setup->Custom posts slug translation options you have the "Translate custom posts slugs (via WPML String Translation)." option enabled.
b) In WPML->Translation Management->Multilingual Content Setup->Custom posts you have the "Use different slugs in different languages for CustomPostType." option enabled for Products and all slugs are correctly translated there.

If everything seems to be correctly set or you use a 3rd party plugin to create custom slugs, please open a new ticket so we can focus on this issue there. Describe the situation and what you already checked, include the debug information again. Also, if it's okay with you, share the credentials to your site and FTP. This would speed up the troubleshooting process.
You may assign the ticket to me during the ticket creation. I'll be happy to help you with the issue.

3. As I can see in your debug information, your PHP memory limit is set to 512M (so that's great) but the WP Memory Limit is set to 40M (that is a default WordPress setting).
Please add the following lines to your wp-config.php file:

define( 'WP_MEMORY_LIMIT', '128M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

You may increase the limits up to 512M since this is how much you have available on your server.

If you still have the issue with the WP Memory Limit increased, please also create a new ticket for this issue.

4. It's probably a compatibility issue since the plugin is not on our compatibility list. However, it's good to confirm that it's not just a matter of settings. Please open another ticket for this issue. Also, describe what you've already tried and share the site and FTP credentials, if possible.

In addition, you can find the list of plugins that are officially compatible with WPML at

Since the original issue reported in this ticket seems to be resolved, please confirm that and mark the ticket as resolved.
For any other issue please open a separate ticket so we can focus on a specific issue in each ticket. As I mentioned above, you may assign those tickets to me and I'll be happy to assist you further.

August 31, 2017 at 6:58 pm #1355536

Alex Paulsen

Thank you, I 'll open a new ticket now.