This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.32 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Yvette 3 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
June 3, 2019 at 8:05 am

jean-paulS

I am trying to: preview pages and posts inside a Divi builder module

Link to a page where the issue can be seen: all the modules in Divi builder for the Dutch pages and posts
I expected to see: the preview of the page

Instead, I got: a white bar

Hi,

Two weeks ago, I contacted WPML support because I couldn’t preview my pages and posts on the Dutch (NL) part of my bilingual (EN-NL) website. Support advised me to disable “Auto sign-in and sign-out users from all domains" from WPML -> Languages. I did so, and it resolves the issue. But there is still a problem: when I am in the Divi builder of a Dutch page or post, and I want to check a change with the “eye” at the bottom of the Divi (text) module, instead of a preview, I got a white bar. This also only occurs on the NL pages and posts. URL is hidden link, subdomain is hidden link. Website is alive but hidden for search bots.
Thanks in advance and kind regards.

Jean-Paul

PS With the WPML plugins deactivated, the preview works.

June 3, 2019 at 4:00 pm #3944039

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

My suspicion is that this has to do with the setting to login/logut of the various domains that has been disabled.

In the picture that you uploaded, you are attempting to preview an NL page while in the EN domain. If you change the URL base to be "jouwindiversum.net", does the white bar still appear?

I was unable to test this myself since I do not have proper login credentials.

I wait for your feedback.

June 4, 2019 at 7:50 am #3948827

jean-paulS

Hello Yvette,
Thanks for your reply.
I don’t know what you mean by “change the URL base to be ‘jouwindiversum.net.’” If you mean that the Language URL format for Dutch (NL) must be set to “A different domain per language, “ I already did that earlier. But when previewing an (NL) page or post, “yourindiverse.net” is used instead for some reason. I suppose it's the usual way, perhaps because yourindiverse.net is the main domain, and jouwindiversum.net is a parked domain. This, however, is not a problem when previewing the whole page (by clicking “preview” or “Preview Changes.”- see screenshot). It’s only an issue when previewing a module in the Divi builder.
The token I’ve sent works when I try it. Can you try it again? If it doesn't work, I'll send you a new one.
Kind regards,
Jean-Paul

June 4, 2019 at 8:01 am #3948979

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi

1. You wrote: "when previewing an (NL) page or post, “yourindiverse.net” is used instead for some reason. .."

This is what I meant about changing the URL "base". When you want to preview an item, normally, you should be able to change the URL base "yourindiverse.net" part to be "jouwindiversum.net".

When I attempt to change the domain in the dashboard URL to be the active domain for the NL language, I am being forced to re-login so the token you gave me is not valid for the 2 domains.

My experience with pagebuilders and the setting for domains-per-language is that you need the setting “Auto sign-in and sign-out users from all domains" to be enabled.

2. you wrote: "... I suppose it's the usual way, perhaps because yourindiverse.net is the main domain, and jouwindiversum.net is a parked domain.."

I would have expected your server configuration to have used an "alias" instead of a "parked" domain. Server providers tend to use their own terminologies for what they define in the DNS records...but can you double check that you can do the following "test".

You can login to the wp-admin of each domain and reach the dashboard with the URL of the dashboard displaying the domain of the active language?

THanks

June 4, 2019 at 9:39 am #3949831

jean-paulS

Hi,
1.
A. You wrote; “When you want to preview an item, normally, you should be able to change the URL base 'yourindiverse.net' part to be 'jouwindiversum.net.'”: where can I change this? (I have no idea)

B. you wrote: “When I attempt to change the domain in the dashboard URL to be the active domain for the NL language,”: where do you exactly want to change this? I want to see if I have to re-login too. And if it changes something concerning the issue.

C. I disabled "Auto sign-in and sign-out users from all domains" just because I couldn’t preview my pages or posts (suggestion from WPML support). I enabled it again now, and strange enough, I can preview my pages and posts now anyway (with the correct NL domain URL). Previewing from within a module, however, remains not possible.

2. You wrote: “You can log in to the wp-admin of each domain and reach the dashboard with the URL of the dashboard displaying the domain of the active language.” : when I log in with “jouwindiversum.net/wp-admin,” I’m automatically redirected to “yourindiverse.net/wp-admin.” End of the test?

June 4, 2019 at 2:11 pm #3952295

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

From what you wrote, it might be that your domain alias is not setup correctly. Please see what I mean about having the active language domain present in the wp-admin URL.

I believe this is important because the preview will attempt to use the same domain to generate the view of your module.

So, if you cannot log into each domain and have the dashboard retain the correct domain (e.g. it should not redirect) then this is something I would ask you to check with your server provider to help you with.

June 5, 2019 at 8:18 am #3957977

jean-paulS

Hello Yvette,

I took a look at my parked domains in cpanel and noticed that “jouwindiversum.net” was not redirected (see screenshot). When redirecting it to ”jouwindiversum.net itself” (see the second screenshot), I was able to login into “jouwindiversum.net/wp-admin.” But when previewing it from within a Divi module, I got an error message (see the third screenshot- I translate: “The page does not redirect correctly. Error while connecting to yourindiversum.net. This problem can sometimes be caused by disabling or refusing cookies.”) Same thing when previewing from within an editing page.

I think that the best thing I can do is contacting Divi support first and ask their opinion. They have the most experience with their builder.

Thanks for the support so far, and I’ll keep you informed.

Kind regards,
Jean-Paul

June 5, 2019 at 10:38 am #3959595

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK.

In the meantime, I will try setting up Divi Builder on my local server to see if I can replicate your error.

If I understood correctly, it has to do with previewing a Divi module. I will be waiting for your news from Divi support.

Thanks

June 13, 2019 at 1:02 pm #4013081

jean-paulS

Hello Yvette, just wanted to let you know that I first contacted Siteground, and afterward Divi support. They discovered that it is a bug that is causing this trouble and are working on it. I will keep you informed once I have more news.

June 13, 2019 at 4:24 pm #4015617

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - thanks for that!

July 5, 2019 at 7:06 pm #4153599

jean-paulS

Hi Yvette,
I just got an email from a support cleanup robot, asking me if the issue is resolved or if I still need support. But as I wrote, Elegant Themes Support was working on it, and they still are. So I write this message to prevent the robot from marking the issue as resolved.
Kind regards

July 8, 2019 at 7:47 am #4159605

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Perfect - understood and good idea.

The topic ‘[Closed] White bar instead of module preview in Divi for translated pages’ is closed to new replies.