This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Itamar 3 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
June 18, 2019 at 3:18 pm #4044757

florinD-3

On The english version of my homepage are those annoying white bars, and i don't understand why.

June 18, 2019 at 3:39 pm #4044941

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and welcome to WPML Support!

While waiting for one of my teammates to take care of your case, can you please let us know what is the website that you are referring to and attach a screenshot or screen recording of that area that you are referring to with the white bars?

Also, can you please paste the WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

Thank you very much!

Kind regards,
Mihai

June 20, 2019 at 8:53 am #4057761

florinD-3

Here 🙂

BR

June 20, 2019 at 3:36 pm #4061039

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see this issue on your site.

In the default language homepage, I can see that there is some inline CSS directive that cancels the 70px padding on the #main content div. A CSS directive that is coming from your theme. Please see the attached screenshot no-padding.jpg. But on the English translation, this CSS directive is not there. And therefore the padding directive from the theme is taking effect. Please see the attached screenshot 70-padding.jpg.

Please let me have access to your site, and I'll try to assist you with this issue.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

June 20, 2019 at 6:27 pm #4062311

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

The homepage translation is not 100% complete from the German language to the English language. Please see the attached screenshot. Can you please 100% complete it and see if the issue gets resolved?

Thanks,
Itamar.

June 21, 2019 at 6:31 am #4064925

florinD-3

Hi Itamar,
i now translated it but it didnt change..

BR

June 23, 2019 at 11:15 am #4072933

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I couldn't find where the CSS directive to cancel the padding on the div with the id of 'main' coming from. But I was able to disable this padding on the English translation of the page by adding the following CSS directive in Appearance -> Customize -> Additional CSS.

#main.sidebar-none.sidebar-divider-vertical {
    padding-top: 0px;
    padding-bottom: 0px;
}

Please see the attached screenshot additional-css.jpg
Now there is no white padding on the ENglish translation of the page.
Please see the attached screenshot no-padding-on-en.jpg.

Can you please confirm that it is OK now?

Thanks,
Itamar.

The topic ‘[Closed] White bars on english page’ is closed to new replies.