This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Noman 7 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
February 26, 2019 at 7:25 pm

daniv

We are having problems with the installation ...
When activating wpml, and entering the plugins screen, a blank screen appears occasionally.
Also, when entering the screen of the "languages" screen, it does not load 100x100 and I can not edit anything.

I attached a couple of screens in case they can help:
- In the first, I show you the languages screen
- On the other hand, I see that your meter indicates that we are only dedicating 40mb of ram to wordpress, when in fact we are dedicating more than 512mb

February 27, 2019 at 8:13 am #3248803

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

- If you have just installed plugin and configuring WPML first time on this site and do not have any translated data yet then you can fix this issue by removing WPML and all its data completely from database, To do so, please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

- After deleting all data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

This issue usually happens due to some corruption in the database, if you are installing WPML first time in this site and you see some database tables starting with <srtong>icl_</srtong> even after reset, please also delete those tables and try reinstalling WPML.

Thank you

February 27, 2019 at 8:39 am #3248944

daniv

Hi Noman,
i follow your instructions, but the problem continues 🙁

February 27, 2019 at 9:32 am #3249263

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- We have released updated version of WPML plugins. Can you please take a backup of your site and update ALL WPML plugins.

If still issue persists, please enable error reporting in you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

- After adding above code then go to WPML >> Languages page, this will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

February 27, 2019 at 10:06 am #3249461

daniv

Hi,
the Wp memory limit it's now OK, and i erase/reainstall with tle last update of WPML...
The white page, seems that it's dissapear, but we have the same problem in "languages" option 🙁

I send you the wp debug and the wpml debug too:
hidden link

THANKS!

February 27, 2019 at 12:24 pm #3250088

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have examined your debug.log file and all errors are coming from your theme. Could you please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If still issue persists, Please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

The topic ‘[Closed] White page / Languages options’ is closed to new replies.