This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 3 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 21, 2019 at 1:30 pm #4067501

martinF-45

I am trying to:
- update these 3 plugins

WPML Multilingual CMS
Máte inštálovanú verziu 4.2.6. Aktualizujte na 4.2.7.1. Zobraziť detaily verzie 4.2.7.1.
Kompatibilita s WordPress 5.1.1: Neznáma
Kompatibilita s WordPress 5.2.2: Neznáma
Vybrať WPML String Translation

WPML String Translation
Máte inštálovanú verziu 2.10.4. Aktualizujte na 2.10.5.1. Zobraziť detaily verzie 2.10.5.1.
Kompatibilita s WordPress 5.1.1: Neznáma
Kompatibilita s WordPress 5.2.2: Neznáma
Vybrať WPML Translation Management

WPML Translation Management
Máte inštálovanú verziu 2.8.5. Aktualizujte na 2.8.6.2. Zobraziť detaily verzie 2.8.6.2.
Kompatibilita s WordPress 5.1.1: Neznáma
Kompatibilita s WordPress 5.2.2: Neznáma

- on WordPress less than 5.2.2 (into this version I cannot upgrade due to old PHP)
- but with PHP 5.4.45-0+deb7u7

Link to a page where the issue can be seen:
- hidden link
- it had been resolved because the site needs to work by removing plugin directories after update:
sitepress-multilingual-cms / the problem was probably here
wpml-string-translation
wpml-translation-management

I think the problem might be due to the incompatibility of these updates with older PHP. Can you check it for me?

June 23, 2019 at 3:57 am #4072555

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

You are right about the PHP version as WPML needs at least PHP 5.6 to function correctly. you server runs PHP 5.4.45 and mySQL 5.5.54. I would even advise you to install at least PHP 5.7 and my SQL 5.6 or higher and the issue should be solved. Higher version will lead to a better performance as well.

https://wpml.org/home/minimum-requirements/

Additionally, after proceeding the updates could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 268435456M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version2.

In case of any doubt please contact your hosting provides and ask for assistance.

Let me know if you need further assistance.

Kind regards
Andreas