This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.75 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to setup WPML. Unfortunately every time on 3rd step I see blank screen and I can not finish WPML setup.

Solution: You can fix this issue by enabling eval() php function This function must be enable in your site as WPML uses TWIG framework for its structure and templates, which makes WPML dependable on this php function. You need to contact your website hosting support and let them know to enable this function for your server / site. https://wpml.org/home/minimum-requirements/

This topic contains 3 replies, has 2 voices.

Last updated by szymonG-2 1 year ago.

Assigned support staff: Noman.

Author Posts
October 5, 2018 at 9:25 am #2790129

szymonG-2

Hello,

I am trying to: setup WPML. Unfortunately everytime on 3rd step I see blank screen and I can not finish setup WPML.
I have attached image with that screen.
Could you help me please resolve that problem?

Thank you.

Kind Regards,
Tomasz Banach

October 8, 2018 at 7:43 am #2794951

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

- If you are configuring WPML first time and do not have any translated data then you can fix this issue by removing WPML and all its data completely from database, To do so, please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

- After delete all data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

- If above does not resolve the issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 8, 2018 at 6:47 pm #2797108

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled error logging at your site by adding following code in your site’s wp-config.php file:

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

And it’s showing following errors in debug.log file inside wp-content folder.

[08-Oct-2018 17:19:16 UTC] PHP Fatal error:  Uncaught Twig_Error_Runtime: Failed to load Twig template "template.twig", index "": cache is corrupted in "template.twig". in /www/rkrodo_www/www/rodo.rklegal.pl/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php:467
Stack trace:
#0 /www/rkrodo_www/www/rodo.rklegal.pl/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php(362): Twig_Environment->loadTemplate('template.twig')
#1 /www/rkrodo_www/www/rodo.rklegal.pl/wp-content/plugins/sitepress-multilingual-cms/classes/templating/class-wpml-templates-factory.php(64): Twig_Environment->render('template.twig', Array)
#2 /www/rkrodo_www/www/rodo.rklegal.pl/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-template.php(62): WPML_Templates_Factory->get_view()
#3 /www/rkrodo_www/www/rodo.rklegal.pl/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-render.php(80): WPML_LS_Template->get_html()
#4 /www/rkrodo_www/www/rodo.rklegal. in /www/rkrodo_www/www/rodo.rklegal.pl/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php on line 467

You can fix this issue by enabling eval() php function This function must be enable in your site as WPML uses TWIG framework for its structure and templates, which makes WPML dependable on this php function. You need to contact your website hosting support and let them know to enable this function for your server / site.
https://wpml.org/home/minimum-requirements/

Thank you

October 11, 2018 at 1:14 pm #2808320

szymonG-2

After enabling eval() php function everything is working good.
Thank you.

Kind Regards,
Tomasz Banach