This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.57 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by harrisD 2 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
July 28, 2019 at 11:09 am #4295417

harrisD

Trying to access the MPML settings page all page covered with white space and setting are not accessible

July 28, 2019 at 2:15 pm #4295555

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

There could be many reasons for this.
We can see a readable error on your white screen if you enable the WP Debug mode.

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) or the error message you see here for me to check.

Let me know.

Regards,
Riffaz.

July 28, 2019 at 3:02 pm #4295601

harrisD

here is the log:
[28-Jul-2019 14:58:30 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_f3hsa4options ( `option_name`, `option_value`, `autoload` ) VALUES ('wpml.WPML_ST_DB_Cache.lock', '1564325910', 'no') /* LOCK */ made by require_once('wp-admin/user-edit.php'), require_once('wp-admin/admin.php'), require('wp-admin/menu.php'), require_once('wp-admin/includes/menu.php'), do_action('admin_menu'), WP_Hook->do_action, WP_Hook->apply_filters, duplicate_post_menu, __, translate, apply_filters('gettext'), WP_Hook->apply_filters, icl_sw_filters_gettext, icl_translate, WPML_Register_String_Filter->translate_by_name_and_context, WPML_Displayed_String_Filter->get_translation, WPML_ST_DB_Cache->get_translation, WPML_ST_DB_Translation_Retrieve->get_translation, WPML_ST_DB_Translation_Retrieve->load, WPML\Utilities\Lock->create

July 29, 2019 at 4:35 am #4296879

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I escalated this to our second tier support.
Please be patient till we get back to you.

Regards,

August 1, 2019 at 8:16 am #4319585

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for your patient.

Please go to WPML > Support > troubleshooting and then recreate the ST Tables: hidden link
Then check the issue.

Let me know how it goes.
If that does not help we will have to copy your site and check this internally.

Regards,

August 2, 2019 at 7:59 am #4327843

harrisD

My issue is resolved now. Thank you!