This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Jamal 8 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
February 6, 2019 at 3:19 pm #3166266

jurreG

I am trying to set up the wholesale prices using the wholesale prices premium plugin. When I set a wholesale price in the Dutch version of a product, the regular price is shown to a wholesale customer in the English version. At the WPML settings I tried to resolve this by changing the status of all the wholesale custom fields ("wholesale_customer_have_wholesale_price", "wholesale_customer_variable_level_wholesale_minimum_order_quantity", etc) from "Don't translate" to "Copy" but that doesn't work. The wholesale prices are not translated and besides this when trying to translate a product via the WooCommerce multilingual page the custom fields are gone..

February 7, 2019 at 11:13 am #3169780

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

You may also need to set the custom field "wholesale_customer_wholesale_price" to copy in WPML->Settings->Custom Fields Translation.

IF it does not help, let me know, i will create a clean server where we will upload the plugin and investigate this incompatibility.

Best regards,
Jamal
WPML Support

February 7, 2019 at 11:20 am #3169800

jurreG

Hi Jamal,

I did already, I set all the "wholesale" custom fields to copy, also the one you mention.

Regards, Jurre

February 7, 2019 at 2:19 pm #3170697

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback, i have created a clean server so we can isolate this issue from your live server. Please use the credentials in the previous private message.
Upload your plugin, and reproduce this error. Once reproduced, i will push it to the compatibility team.

Best regards,
Jamal
WPML Support

February 7, 2019 at 4:05 pm #3171225

jurreG

Hi Jamal,

I don't really understand what to do. I uploaded the wholesale plugin, but I can't reproduce the error because at the WPML settings there are no custom fields to select. My knowledge about web development is limited so maybe that is the problem. Could you give some more step by step info on what to do?

Thanks, Jurre

February 7, 2019 at 4:19 pm #3171280

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I guess you will need to
- Create a wholesale user.
- Create a product and add a wholesale price.
- Translate the product.
- Connect with the wholesale user to check if the price shown for the translated product is the wholesale price or the regular price.
If it is the regular price, it is reproduced. We will push it to our developers to fix it.
If it is the wholesale price it is not reproduced and then we should check further in your website what's causing that.

Please do not upload all plugins, only the wholesale plugin, WooCommerce and WCML and WPML plugins are already there.

Does this makes sense, let me know if you have any doubts.

Best regards,
Jamal
WPML Support

February 8, 2019 at 10:30 am #3174460

jurreG

Hi Jamal,

I did all that, but now when I log in as wholesale customer it doesn't even show the product at all in a different language. So a different error this time..

Regards, Jurre

February 8, 2019 at 12:16 pm #3174973

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I was able to see the translated product in secondary language for the wholesale user(wjamal) i have created.
I did not show the wholesale price.

As a workaround, i switched editor to native WooCommerce Editor in WooCommerce->WooCommerce Multilingual->Settings.
Then i edited the product translation and set the wholesale prive, and it did show successfully in the frontend.
Test this page with the wholesale user hidden link
My wholesale user is [wjamal / 12312312].

Let me know if this workaround works for you.

Please remember to update WPML to latest releases after a full backup.

Best regards,
Jamal
WPML Support

February 10, 2019 at 12:59 pm #3179728
jurreG

Hi Jamal,

Yes, the workaround works, so will use that. Thanks. Another thing: I do have issues updating WPML:

With WPML Media and WPML Multilingual CMS I receive an error: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

And with WPML String Translation and WPML Translation Management: Download failed. Not Found

Regards, Jurre

New threads created by Jamal and linked to this one are listed below:

https://wpml.org/forums/topic/error-pclzip_err_bad_format-updating-wpml-plugins-2/

February 11, 2019 at 9:22 am #3181610

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. Please note that as of WPML 4.2 you can use translation editors or manual translation per site level and per post level. Which means you can set manual translations for some products, and set editor translations for the rest of the site.

However for support rules we are able to handle only one issue at the time. This help us to bring you a better service and also help other users to find all the information here exposed.
For that reason i have create another ticket to handle the WPML update issue. I will be posting my reply there.
https://wpml.org/forums/topic/error-pclzip_err_bad_format-updating-wpml-plugins-2/

Let me know if you still need assistance with the wholesale price issue.

Best regards,
Jamal
WPML Support