This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Sergio 2 years, 7 months ago.

Assigned support staff: Vincenzo.

Author Posts
October 14, 2017 at 6:43 pm #1401065

Sergio

Hello, I am using a new WP and a new theme which is compatible with WPML.
I duplicated the homepage, and when I try to edit the translation it only allows me to edit the Title of the page. See attached.

How can I translate all the content of the page?

October 16, 2017 at 2:26 pm #1402136

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

It seems like there is an issue with the config file.

Try the following steps:

- Go to Plugins> Add New> Commercial.
- Click the "Check for updates" button
- Complete the homepage translation (100%)
- Edit the original homepage adding one element (shortcode)
- Save
- Translate again

Please let me know if this solves the issue or if you need further details.

Thank you

October 16, 2017 at 2:40 pm #1402150

Sergio

I did the following:
- Go to Plugins> Add New> Commercial
- Click the "Check for updates" button (there were no updates)

And can you please explain me the following steps?
- Complete the homepage translation (100%)
- Edit the original homepage adding one element (shortcode)

What do you mean by it?
When I enter to edit the English version of the Homepage. I see it like this. See attached - home-wpml.png

When I click on that thing I marked with a red arrow, I get into the page I made a screenshot of on the first post ticket.

What should I do now?

October 16, 2017 at 2:51 pm #1402174

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

the "spinning" icon means that the old translation is not complete.

- Click on that "spinning" icon.
- Translate the title of the page in Polish
- Select the "Translation is complete" checkbox
- Save and close the translation (It needs to be 100%)
- Edit the original homepage adding one element (shortcode)
- Save
- Translate again. You should see a different icon now
- Now you should see all the content ready to be translated.

Please let me know if this solves the issue.

Thank you

October 16, 2017 at 2:57 pm #1402183

Sergio

I did it until:
- Select the "Translation is complete" checkbox

When I did it, now I see a pencil on the English version. If I click the pencil I still see the page that asks me to translate the title. So it seems I can't edit the Polish translation yet.

Please clarify:

- Edit the original homepage adding one element (shortcode) - which page? The English or Polish page? What shortcode to add? I don't have the shortcode plugin in this blog. Where should I add it?
======

October 16, 2017 at 3:04 pm #1402197

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

from what I can see the original Homepage is the English one.
- You need to edit the original homepage adding some element using the Fusion builder.
- Save
- Translate again to Polish

If this procedure is not working, you may try the manual translation.

Follow these steps:
❌ Before proceeding please make a full website backup! ❌

- Go to WPML -> Translation Management -> Multilingual Content Setup
- Find the "How to translate posts and pages" section
- Enable the "Create translations manually" option
- Save

Now you should be able to translate the pages using the same WordPress interface for both languages.

Please let me know if this solves the issue or if you need further details.

Thank you

October 16, 2017 at 4:24 pm #1402358

Sergio

Thank you. It worked. When I added a test block code element, and updated, then I could edit the Polish page (English version of blocks was in the left, and Polish in the right).

Then I tried to edit the slider in the homepage. I created the translation and once again I have the same problem.
Now it's 100% complete. But in the slider I can't add a new element.

I tried to edit some texts in the original version, but still even after saving, when I click on the pencil I see the titles still.

Why do I have to always edit something before translating the page?
What can I do to translate this slider?

October 17, 2017 at 2:56 pm #1403593

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

it may be necessary to enable the Manual translation.

Please follow these steps:
- Go to WPML -> Translation Management -> Multilingual Content Setup
- Search the "How to translate posts and pages" section
- Enable the "Create translations manually" option
- Save

Now you will be able to use the standard WordPress editor for the translations.

Related documentation:
https://wpml.org/documentation/translating-your-contents/

October 19, 2017 at 11:25 am #1405790

Sergio

it seems everything fine with manual.
Thank you

October 19, 2017 at 11:33 am #1405796

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

our developers are working to improve the Translation editor and fix the remaining issues.
In the meantime, you can work with the standard WordPress editor for the translations.

Please follow our blog at https://wpml.org/blog/ for any updates.

Please let me know if you need further details or if I can count this ticket as solved.

Thank you

October 19, 2017 at 12:47 pm #1405912

Sergio

It' good to close it. Thanks.