This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by piotrB-18 5 months ago.

Assigned support staff: Noman.

Author Posts
May 14, 2019 at 9:49 am #3805477

piotrB-18

Hello,

I can buy and instal WPML Translate and my language switcher is top bar is crashed? How to fix it?

Actually display language switcher is no flag and "(" words unnecessary.

how to set it to display as on the page: hidden link

Best regards

May 14, 2019 at 9:55 am #3805561

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support.

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 14, 2019 at 10:34 am #3805933

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WP login info that you have provided is not working here. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

May 14, 2019 at 10:48 am #3806113

piotrB-18

Sorry, please try now login in WP-ADMIN.

Best regards

May 15, 2019 at 5:21 am #3812339

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I am working on it to resolve this issue and I’ll get back to you shortly.

Thank you for your cooperation and patience.

May 15, 2019 at 6:54 am #3812679

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Example site switcher was build according to Polylang plugin language switcher that’s why its not rendering correct CSS in WPML as WPML have different css classes than Polylang.

I have fixed this issue by doing below steps:

- I have selected ‘Vertical List’ language switcher from WPML >> Languages > Custom Language Switchers > Customize button

- Added below CSS:

.topbar-lang-switcher .wpml-ls-legacy-list-vertical{
padding: 8px 0;
}

.topbar-lang-switcher ul:hover li, 
.topbar-lang-switcher ul li.wpml-ls-current-language {
    display: block;
}

.topbar-lang-switcher ul {
overflow: visible;
}

.topbar-lang-switcher .wpml-ls-legacy-list-vertical>ul {
position:absolute;
}

.topbar-lang-switcher .wpml-ls-legacy-list-vertical li {
margin-bottom:15px;
}
.topbar-lang-switcher ul:hover {
    max-height: 230px;
}

in WPML >> Languages > Additional CSS section.

- Went to WPML >> Languages >> Edit Languages and added languages codes e.g. EN / FR in Translation textboxes.

And now it looks as in the attached screenshot.

Thank you

May 15, 2019 at 10:35 am #3814983
piotrB-18

Nice work. I'm impressed. Thank you very much.

I have one more question.
How to add language switcher in menu mobile phone?
as in the picture in attachment.

Best regards

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/how-to-add-language-switcher-in-mobile-menu/

May 15, 2019 at 10:40 am #3815035

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Glad to see your language switcher issue is resolved. To handle new question/issue, I have created a new tickets since this is a separate issue. Here is the link to the new ticket: https://wpml.org/forums/topic/how-to-add-language-switcher-in-mobile-menu/

You may mark this ticket as resolved and we will continue to work on the new ticket.

Thank you for your cooperation and patience.

May 15, 2019 at 10:46 am #3815073

piotrB-18

My issue is resolved now. Thank you!