This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to Translate footer widgets by choosing the language inside the widget to be a language from drop down - screenshot below. When I choose the language and save it, it automatically change it back to "All Languages". And then I have all the language versions in my footer. https://cdn.wpml.org/wp-content/uploads/2019/05/3912963-Na_ytto_kuva_2019_5_29_kello_10.20.33.png?x34514

Solution: Client used Multilingual text widget and it solved the problem.

This topic contains 2 replies, has 2 voices.

Last updated by anniT-2 4 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
May 29, 2019 at 8:21 am #3912963

anniT-2

I am trying to: Translating footer widgets by choosing the language inside the widget to be a language from drop down. When I choose the language and save it, it automatically change it back to all language. And then I have all the language versions in my footer

Link to a page where the issue can be seen: hidden link

I expected to see: I just want to have the translation for all the languages

Instead, I got: Everything together

May 29, 2019 at 8:51 am #3913535

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

=== Please backup your database and website ===

Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

- PHP is 5.6.36 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

- Please upgrade your server’s MySQL version to a higher level: https://wpml.org/home/minimum-requirements/
MySQL 5.5.5 version in your site, is lower than the required for WPML.

- You are using older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.1.

- Please delete all sort of caches on your site / server cache (if any) / plugin cache (WP Rocket Cache) / CDN cache (if any), clear browser cache and then check the page.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

May 29, 2019 at 12:20 pm #3915311

anniT-2

I actually found another widget. Multilingual text. I used that and it worked this out!