This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by christophS-10 5 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 27, 2019 at 5:30 pm #3695983

christophS-10

I am trying to: Set the languageof widget with the language drop down.

Link to a page where the issue can be seen:walter-bohrtechnik.de

I expected to see: Language setting for widget is english

Instead, I got: After clicking on save, dropdown switches back to All languages. WPML Widgets is installed - same issue.

April 28, 2019 at 5:21 am #3697233

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is very strange.

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

May 3, 2019 at 6:16 am #3731071

christophS-10

It is indeed a compatibility problem. The Core Plugin of the theme causes the problem. Thanks for you help anyway.