This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Andrés 1 month, 1 week ago.

Assigned support staff: Andrés.

Author Posts
September 6, 2019 at 8:51 am #4524155

harrisD

I have translated widgets, but they are not visible in left side bar area.

September 6, 2019 at 9:10 am #4524243

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

1. If you add a new widget in your Sidebar area and you don't translate it, does it appear in all languages?

2. Could you please verify that your widgets has been set as "All languages" on the bottom?

3. Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:
- MemoryLimit 512M
- WP Memory Limit 40M

Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Best regards,
Andrés

September 6, 2019 at 9:21 am #4524315

harrisD

1. No.
2. Widgets are in "all languages
2. I raised memory limit as instructed.
3. Cleared cache.
4. Memory settings from my providers is 512

The only page with visible widgets is:
hidden link

All other no.

I used a little trick that seems to solved the problem.
I do some minor changes to english version, then edit the Greek version and the appropriate field is there to translate..
So, this is solved, BUT, there is an option to hide the "share" buttons in English version. Even i disable this, they are still visible in Greek

I have a similar problem in home page. It is translated, but pressing on logo, goes to English version

September 6, 2019 at 1:26 pm #4525487

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Sounds like a compatibility issue. On your test site, please check if this issue appears when:
- Only WPML plugins are activated. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.