This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Riffaz 1 week, 5 days ago.

Assigned support staff: Riffaz.

Author Posts
September 13, 2019 at 6:16 pm #4570369

katiaT

I am trying to:

Have the hero widget (Evolution statt stagnation) be displayed in English on the English site integral-evolution.com.

Link to a page where the issue can be seen:

hidden link

I expected to see:

This widget translated to English. I translated the text in the string translation area, at least I think it says I did.

Instead, I got:

a missing hero widget on integral-evolution.com and the German widget only on the site integraleevolution.de.

What I also don't know is why WPML has not copied the build-up of the German page. If I duplicate the widget and have it once in English, once in German, it will show double on the German site. If I have it only once, it will not show in the structure of the English site integral-evolution.com.

September 15, 2019 at 7:32 am #4574075

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

There is a easier method to do this. please refer: https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

Let me know how it goes.

Regards,
Riffaz.

September 15, 2019 at 8:27 am #4574169

katiaT

Hi Riffaz, This was the first thing I tried, doesn't solve my problem. Kind regards, Katia

September 16, 2019 at 6:44 am #4576617

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Then it should be compatible issue and I could not find the plugin you are using in our compatible list: https://wpml.org/documentation/plugins-compatibility/

Please :
1. go to hidden link
2. configure the WPML as you have it on your site. at the last step (sitekey) just click next.
3. install the plugin you are using for this widget.
4. create only one page/post
5. set the widget
6. translate it.
7. reproduce the issue.
8. let us know how to check this step by step and show some screenshots.

You may think you do not have enough time to do this but it will take only 5 to minutes as everything is already pre-configured.

Let me know.

Regards,

September 16, 2019 at 9:48 am #4578131

katiaT

Hi Riffaz,

I tried to do what you suggested. Just to be clear: I already had the option in the widget to display it in all languages. However, this didn't do anything. Your configuration also didn't help. I am uploading my screenshots. I'd be grateful if you could take another look. Thank you. Katia

September 16, 2019 at 7:30 pm #4583651

katiaT

Hi Riffaz, there is another issue that WPML is causing. I can't save pages at all anymore. I talked to the support of my theme and they asked me to reach out to you. They are happy to incorporate any needed fixes in their theme, but you would have to fix this issue first.

Thank you, Katia

September 17, 2019 at 9:23 am #4587029

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

HI,

Thank you for the sandbox setup.

I do not see that you installed the plugin "hero widget (Evolution statt stagnation)" and configured.
Please install it and recreate the issue.
Then only we can check the issue and then we can find the fix for that.

You missed these steps:
3. install the plugin you are using for this widget.
4. create only one page/post
5. set the widget
6. translate it.
7. reproduce the issue.
8. let us know how to check this step by step and show some screenshots.

Regarding the not saving issue:
This is a whole different issue from the initial question of this ticket.
Please open a new ticket for this to avoid the confusion and to reduce the waiting time.

Regards,

September 17, 2019 at 2:57 pm #4589525

katiaT

Hi Riffaz,

I am quite sorry, but I don't exactly know what to do reading your instructions.

3. The plugin is already installed. It is the organic builder, which is from the same people who have made my theme.
4. I can create a page or post (but probably not save it). However, I can't set (what do you mean by "set the widget"?) a widget into any site or post. I can only put the widget in the widget area, where it is already installed. You seem to be referring to another widget that I should create. Where would that be? In a site or post? I couldn't find anything there.
7. What do you mean by reproduce the issue? Which issue?

Please give me a more detailed information on what to do.

I will gladly give you my login data so you can do whatever is needed, if that helps.

September 18, 2019 at 12:35 pm #4596589

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I do not see your theme here: hidden link
I do not see the plugin you mentioned either : hidden link

So I am not sure how to check this.

we can test your site but checking this in fresh installation will help a lot to find the accurate fix for this.

Let me know your site login details to check this in your site as well.
The next reply is private.

Also, let me know how to check this in your site.

Regards,

September 22, 2019 at 1:11 pm #4618649

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

Even if I set English here hidden link I do not see that widget in your English site.
So for sure the Hero Widget you are using is not compatible with WPML as I explained in earlier replies.

Please create a hero widget in the sandbox site as well.
So our developers can work on this to find the fix.

What I am asking is, we need like this hidden link in here as well: hidden link
So basically you have to configure like this : hidden link in sandbox site as well or any other method how you created this in your live site.

Let me know.

Regards,

September 25, 2019 at 6:18 am #4635799

katiaT

My WP tech is looking into this and will get back to you.

September 25, 2019 at 9:02 am #4637043

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, take your time.
Update here when you are ready.

And, please note the sandbox will expired if you don't open it for 7 days continuously.
So make sure you are open it at least once in 7 days.

Regards,

September 25, 2019 at 12:50 pm #4638867

katiaT

Hi Riffaz, The theme should be in the sandbox, along with the plugin:

hidden link

I hope this helps.

We are looking forward to hearing from you!

Kind regards, Katia

September 26, 2019 at 6:36 am #4643733

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for this.

This is the German page in sandbox: hidden link
This is the English translation of that page: hidden link

Bothe pages have the widget. so the widget works fine in sandbox.
So widget and the WPML works fine.

Some setting or any specific configuration make this issue in your site.
Could you please disable all the third party plugins except WPML and Hero widget and check the issue?
Do you see the same issue?
if yes, we need to check your site by duplicating it.

Let me know.

Regards,

September 26, 2019 at 2:43 pm #4647829

katiaT

Hi Riffaz,

Yes, you are right. If only the Organic builder (for the hero widget) and WPML stays active, the widget gets displayed.

The culprit is AH display widgets. This plugin allows you to display or exclude widgets individually. I hope that helps!

You are welcome to reproduce my page.

Kind regards, Katia