This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by susanK 1 week, 6 days ago.

Assigned support staff: Andreas W..

Author Posts
September 24, 2019 at 5:36 pm #4633283

susanK

I am trying to: have my widget sidebar appear on both my english and Spanish blog archive page and all posts. At first it did, but was in english on everything, so I deleted the translation so at the least it was in english on my english page. Now that I am coming back to trying to fix this on the Spanish pages, it is gone completely and I can not figure out how to get it back, as I am not able to change the default settings in the Spanish pages.

Link to a page where the issue can be seen: hidden link

I expected to see: a page similar to this, but in Spanish: hidden link

Instead, I got:

September 25, 2019 at 12:18 am #4634571

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

First, make sure to translate the page "Blog" again and check if the English Sidebar will show up on both pages. Let me know if this solved the issue.

In order to translate the widgets, you do actually have two options. You can go to Appearance -> Widgets and create one sidebar Widget for each language, as each language comes with a Language Options to make one appear on each language.

By default, this option is set to both languages, which should make the default language widget appear on both pages.
Those widgets then need to be translated on String Translation. You can filter them by using the domain dropdown and selecting "Widgets".

https://wpml.org/documentation/getting-started-guide/translating-widgets/

Also, increase the WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and no other plugins installed.

Let me know if you need further assistance.

Kind regards
Andreas

September 25, 2019 at 5:30 am #4635735

susanK

Hi Andreas,

Thanks for the quick reply. I successfully changed the memory limit, as per your instructions.

I went back and deleted the previous Blog archive page in Spanish and then translated again the English blog page. However now, there is no Blog archive page in Spanish, even though I seemed to do everything I am supposed to.

I have to be honest that I am *very* new to this and it is the first time I am trying to build a page myself. When I first installed WPML back in August, I followed all of the instructions in the set-up guide, but things were still not looking like I wanted them to, so I just started trying things myself and eventually got it to look like I wanted it to. But, I honestly can't remember what I did!

Would it be easier if you are able to log in to my WP dashboard and take a look at things there?
Many thanks for your assistance!
Susan

September 25, 2019 at 5:56 pm #4641595

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better for a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 29, 2019 at 1:49 am #4659475

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

The issue was that the Widgets were configured to only be visible in English. (See screenshot)
I assigned the setting to "all languages". If you wish to edit the translations you need to use String Translation.

More information here:
https://wpml.org/documentation/getting-started-guide/translating-widgets/

Let me know if you do have any further questions.

Kind regards
Andreas

September 30, 2019 at 4:56 am #4662327

susanK

Andreas,

Thank you so much for this! I can't believe that I didn't find that setting myself.

My only last issue, is that I went in to String Translation to translate the description (body) of the About Me widget (Sobre TC) and I can't find it in the list at all. I see the widget title, but nowhere where I can translate the "A full-time expat teacher who spends free time baking American-style sweet treats in Madrid, Spain". Am I missing something?

Thanks,
Susan

September 30, 2019 at 4:01 pm #4666285

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Some strings, especially if they are based on theme or plugin options, will need to be added manually to String Translation by using the option "translate texts in admin screens" at the bottom of the String Translation screen.

I was able to locate the strings which belong to the domain "widget_contact_info" (See screenshot).

Now, it is necessary to mark the checkbox for each string and scroll to the bottom of the page to apply the changes but for some reasons, the strings do not appear on String Translation.

Before we take any further steps, please try the following.

- Go to PHPmyAdmin and change the value for max_input_vars inside of the php.ini file of the currently used PHP version. You are currently using a value of 1000. Please change it to 3000 or higher. Ask your hosting provider if you need any assistance.

- Disable any additional plugin and try to add the strings only with WPML plugins enabled.

If this will not solve the issue we might handle a compatibility issue between the Sepia Theme and our plugins.

If this is the case, then please let me know in order for us to test the theme for compatibility.

Kind regards
Andreas

September 30, 2019 at 6:07 pm #4667027

susanK

Hi Andreas,

Thank you for the specific message. I did everything you suggested, but the widget body for that "contact_info" is still not in the string translation list when I limit it to Widgets. I think it must be a compatibility issue.

If you could test for compatibility and come up with a way to translate that, it would be amazing.

Thank you!
Susan

September 30, 2019 at 7:26 pm #4667353

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Please install the Sepia Theme and any additional plugins related to the theme onto the following test site:

One-Click Login: hidden link

Leave me a short notification once the components are installed and I will continue with the testing.

Kind regards
Andreas

October 1, 2019 at 4:45 am #4668733

susanK

Hi Andreas,

Everything is installed and ready for testing.

Thanks,
Susan

October 1, 2019 at 3:51 pm #4673617

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for installing the theme on the test site.

While testing I was able to add the strings from the section "translate texts in admin screens" but the translations are not showing up on Front-End.

I have escalated this issue to our compatibility team for further investigation. Please let me know if you spot other Widgets with similar issues.

I will be in contact once I received feedback from our team.

Kind regards
Andreas

October 1, 2019 at 4:22 pm #4673987

susanK

Andreas,

Thank you for letting me know. At this point, this is the only widget I am having trouble with and likely will not need to use any more in the near future.

I will wait to hear word back from you.
Best,
Susan

October 1, 2019 at 11:25 pm #4675653

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please try the following:

Go to Appearance -> Widgets and create a second Widget for the Contact Info (One for each language).
Then assign each Widget to a specific language in the Widget Options. This worked on our test site and I applied the changes to your live site already. Make sure to edit the translation if needed.

Please let me know if this is a suitable workaround for you or consider this ticket as resolved.

Kind regards
Andreas

October 2, 2019 at 4:27 am #4677035

susanK

This is great. Thank you so much for your work, and especially because now it will help me problem solve anything like this in the future. My issue is resolved now. Thank you!