This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 3 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
July 9, 2019 at 12:39 pm

edn-4

I am trying to translate widget's hidden link

Link to a page where the issue can be seen:

I expected to see changes in widget section.

Instead, I got nothing if am translate in default language then effect on all other language with some text and content in widget area.

July 9, 2019 at 3:03 pm #4172213

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have logged in to your site and enabled Widget translation by selecting ‘content’ checkbox from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> widget_custom_html >> 3 and hit apply button.

And added test translation in chinese language from WPML >> String translation and it showing correct translation at frontend as you can see in the attached screenshot.

You can add translation from WPML >> String Translation.

Please let me know if this resolves your issue or you need further assistance.

Thank you

July 10, 2019 at 5:10 am #4176167

edn-4

Thanks for the reply i have an doubt regarding the widget area hidden link
what will be the different between these two widget translation and how you achieve this [widget_custom_html][3]content

July 10, 2019 at 7:39 am #4176703

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

‘Widgets’ domain belongs to ‘Text’ widget and ‘admin_texts_widget_custom_html’ domain belongs to ‘Custom HTML’ widget. You can see domain name in the first column of WPML >> String Translation table.

I have followed the below steps in order to fix this issue.
- Went to Appearance >> Widgets section and saw the widget name (Custom HTML).
- Then I went to WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” and searched ‘widget_custom_html’ and enabled translation.

Thank you