This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Andreas W. 7 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
February 11, 2019 at 4:46 pm #3184419

sonjaR-2

I am trying to:

edit a widget-text, but it is not possible to edit the field. The field 7 textarea is not active.

February 11, 2019 at 7:20 pm #3185166

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for contacting WPML Support.

Do I understand right that this string is coming from the Image Widget Plugin? This plugin has not yet been tested with WPML.

https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=Image+&wpv_filter_submit=Search

Anyhow, you should be able to translate the HTML code that you see inside the string. I can see that it still includes German text. You will only need to replace the German text for English ones but you will need to make sure to keep the exact structure of the code.

In case you are not able to complete the translation, means it will not show up on Front End it might be that you will need to adjust some settings.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.

You can find the php.ini file on your server inside the folder for your currently used PHP version 7.2.14-he.2.
In case of any doubt please contact your hosting provides and ask for assistance.

Please let me know if this solved the issue.

Kind regards
Andreas

February 13, 2019 at 10:35 am #3193312

sonjaR-2

Dear Andreas,

thank you for your feedback.

I increased WP Memory Limit to 256M.

I changed the iwdget, instead of image widget I took html text.

But my problem still is, I cannot click into the textarea, I can change nothing...

...another fact: after I changed the language of the choasen string, I cannot edit the string, even the title of a widget.

Viele Grüße

Justus Siebert
Web-Entwicklung

February 13, 2019 at 4:46 pm #3195482

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

February 13, 2019 at 11:41 pm #3196466

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Der graue Text in String Translation dient alleine als Platzhalter. Ich habe zuallererst alle Widget strings der Sprache entsprechend angepasst. Dann habe ich den HTML code kopiert und die deutschen Textstellen mit Englischen ersetzt.

Sie können übrigens auf diese Weise auch Links zu PDF Dateien oder Bilder in anderen Sprachen abändern.

Bitte lassen Sie mich wissen, ob Sie weitere Hilfe benötigen.

Mit freundlichen Grüßen
Andreas

February 26, 2019 at 9:00 am #3243589

sonjaR-2

Hallo Andreas,

mir ist die Email-Benachrichtigung durchgegangen, deshalb diese verspätete Rückmeldung, sorry...

Für mich, für das nächste mal zum selber lösen: was heißt "alle Widget strings der Sprache entsprechend angepasst"?

Danke schonmal
Justus Siebert

February 26, 2019 at 2:38 pm #3245486

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Es kommt vor, dass String mit der Sprache in String Translation erscheinen, die vom Plugin als Standard verwendet wird. Man kann diese Sprache für einzelne String ändern (Siehe Screenshot).

In Ihrem Fall Bestand die Text-Strings aus einem kompletten HTML Code, der Links und texte beinhaltet. Ich habe diese der Sprache entsprechend abgeändert.

Ich hoffe die weiteren Screenshot erleutern meinen Vorgang. Sollten Sie noch weitere Hilfe benötigen, so lassen Sie mich es bitte wissen. Ich stehe gerne für weitere Fragen bereit.

Leeve Jröz no Kölle!
Andreas 😀

March 8, 2019 at 12:57 pm #3292320

sonjaR-2

Hallo Andreas,
danke soweit, aber ich habe immer noch nicht gefunden, wo ich den Text übersetzen kann. Wie ich die Sprache für einen String ändern kann habe ich gefunden, aber nicht wo ich den Text dann auch ändern kann. Ich sehe nur den grauen Text in string translation, der nur als Platzhalter dient und nicht editierbar ist:

"Der graue Text in String Translation dient alleine als Platzhalter."

Wo aber kann ich diesen Text nun editieren??

Ich habe jetzt ein neues Widget angelegt (Rechte Sidebar, Titel Platzhalter 1), das taucht auch in den string-Übersetzungen auf, ich habe eines in deutsch übertragen, ich weiß aber nicht, wo ich die Übersetzung jetzt editieren kann.

Oder ist das so: ich muss in die entsprechende Sprache wechseln (oben in der Leiste), in diesem Fall in Englisch, und dann über Design > Widgets das entsprechende Widget editieren/übersetzen? Und wenn ich wieder in Deutsche wechsel, erscheint da nach wie vor der deutsche Text?

Muss die Auswahl dort auf Anzeige: alle Sprachen bleiben, oder die entsprechende Sprache auswählen?

Danke schonmal,

Justus Siebert | Köln

March 8, 2019 at 3:34 pm #3293758

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Sie müssen eigentlich nur in String-Übersetzung den englischen Text eintragen. Der graue Text wird dabei überschrieben. Er dient nur als Orientierungshilfe zum Originalinhalt.

Allerdings bemerke ich nun, dass im neuen Widget der Text nicht im Frontend übernommen wird. Darf ich fragen, wie Sie die Englischen Inhalt im neuen Widget erstellt haben? Ich finde dazu keine Strings. (Siehe Screenshots)

Zu Ihrer Frage, die Widgets lassen sich nicht editieren, indem man die Sprache in der oberen Leiste ändert. Dies wird dazu führen, dass die originalen Widget überschrieben werden.

Mit freundlichen Grüßen
Andreas

March 8, 2019 at 4:01 pm #3294008

sonjaR-2

Hallo nochmal,
was mich irritiert: inzwischen kann ich unter string-translations den englischen Text editieren, was ich direkt nach dem Anlegen des Widgets nicht konnte, da war nur das grau hinterlegte Feld, das ich nicht editieren konnte.

Und: jetzt sind die deutschen string-Texte doppelt drin, siehe screenshot, welcher davon ist den nun der richtige?!

Frontend: ich habe das widget dort noch nicht auslesen lassen, der Text ist zunächst im quellcode fest eingegeben.

March 8, 2019 at 5:01 pm #3294522

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Die Strings waren bereits doppelt vorhanden, was eventuell dadurch entstanden sein könnte, dass das Plugin doppelt erstellt wurde. ich habe dann einfach alle übersetzt.

Ich weiss nicht, warum Sie Schwierigkeiten mit der Übersetzung hatten, aber seitdem ich mich das erste mal angemeldet hatte gab es kein Problem.
Der graue Test darf nicht als Wert angesehen werden.
Sollten Sie versucht haben den grauen Text als Eingabe zu bestätigen, so wird dieser nicht von WPML anerkannt, weil er nur als Platzhalter dient.
Der graue Text ließ sich bei meiner ersten Test auf Ihrer Website direkt überschrieben und speichern.

Zusätzlich habe ich die Strings aus der Option "Text in Admin Bildschirmen Übersetzen" hinzugefügt und wiederholt übersetzt. Sie können diese String gerne aus der String-Übersetzung löschen. Markieren Sie dazu die Chekcbox und wählen Sie die Option zum löschen aus dem Dropdown.

WICHTIG

Könnten Sie mir bitte genauer erklären, wie Sie die Texte eingefügt haben und warum diese weder in Design -> Widgets, noch in String Translation auftauchen?

Haben Sie den Text direkt in Ihre Theme Template-Datei eingesetzt? Sollten Sie Text im Quellcode angeben, so muss dieser einen GetText Call erhalten, um von WPML als übersetzbar angesehen werden zu können.

Mehr zu diesem Thema hier:
https://wpml.org/de/faq/warum-erscheinen-string-ubersetzungen-nicht/

Im Zweifel machen Sie bitte die Änderungen in Ihrem Theme rückgängig und nutzen Sie den WP-Admin und String Translation. Dies sollte ohne Probleme funktionieren. Ich habe es bereits mehrmals getestet.

Mit freundlichen Grüßen
Andreas