This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Lauren 4 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
June 10, 2019 at 6:09 pm #3989503

thomasK-90

I am using Genesis featured page advanced widget and would like to translate them.
I followed the steps described on this page.
https://wpml.org/forums/topic/translate-widgets-created-with-the-plugin-genesis-featured-page-advanced/
However, custom_content is not appearing in String Translation. I could translate the titles.

June 10, 2019 at 7:40 pm #3989977

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Were you able to find the strings in WPML -> String Translation -> Admin Texts? If you found them but were unable to add them to string translation, most likely you need to increase max input vars. You can do this by adding this line to your .htaccess file:

php_value max_input_vars 20000

or by following these steps:
1. Connect to your site via FTP or File Manager
2. Navigate to wp-admin folder
3. Create a file inside wp-admin folder called php.ini
4. Add in this line: max_input_vars = 20000
5. Save

If you don't have access to these files, please ask your hosting provider to do this for you.

June 10, 2019 at 7:54 pm #3990055

thomasK-90

Tried your suggestion, but still I cannot add them to string translation.

June 11, 2019 at 1:15 pm #3995627

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You can try adding them to WPML -> Settings -> Custom XML Configuration. You can follow the steps in this documentation and add the fields there: https://wpml.org/documentation/support/language-configuration-files/

Once you have added them there, they should appear in the String Translation table. Please let me know if you need any further assistance and I will be happy to help.

June 11, 2019 at 5:43 pm #3997783

thomasK-90

I found them in the string tranaslation without Custom XML method. It was simply in other domain than I thought.

Now I translated and some appear on the frontend correctly, but some don't, even they are translated. Why?

June 12, 2019 at 4:49 pm #4006267

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It could be that you have translated the incorrect string, they could be located in a different domain in the admin texts. I'll be happy to take a look if you would like. Please let me know the URL where I can see the strings on the frontend,and also where you go to edit or create the content on the backend.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

June 13, 2019 at 1:17 pm #4013201

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending me access. I see that when you created the content in Appearance -> Widgets -> Front Page 2, you entered the title in English. However, your default language is German. So what happens is that the string is registered in German in WPML -> String Translation. In my screenshot, you can see that the Widget Title has not been translated. I suggest updating the widget title to German. Then, go to WPML -> String Translation and search for the title and translate it to English.

Once you have completed those steps, please let me know if you are still seeing untranslated texts.

June 13, 2019 at 4:35 pm #4015701

thomasK-90

I followed your suggestion but still seeing untranslated texts.

June 14, 2019 at 4:45 pm #4023097

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I found that you can translate these widgets by creating a widget for each language. At the bottom of the widget, you should see the language selector. I set the one you created to DE and then added a new one and set it to EN. Now you can see the correct one showing up in each language for Automotive Aftermarket.

You can follow these steps for the additional widgets. Please let me know if you need any further assistance and I will be happy to help.