This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Ambiense theme is showing widgets on English language only
Solution:
in wp-content/themes/ambiense/include/footer-bars.php replace line 9:

<?php if(is_active_sidebar("ozy-footer-widget-bar-full" . $tmp_lang)) { if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar("ozy-footer-widget-bar-full" . $tmp_lang) ) : ?><?php endif; }else{ esc_attr_e('© ', 'ambiense');echo date('Y'); echo ' ' . get_bloginfo('name');esc_attr_e(', Please go to Appearance > Widgets : Footer Bar Full Width and add some widgets here, e.q; Image, Custom Menu', 'ambiense'); } ?>

with

<?php if(is_active_sidebar("ozy-footer-widget-bar-full")) { if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar("ozy-footer-widget-bar-full") ) : ?><?php endif; }else{ esc_attr_e('© ', 'ambiense');echo date('Y'); echo ' ' . get_bloginfo('name');esc_attr_e(', Please go to Appearance > Widgets : Footer Bar Full Width and add some widgets here, e.q; Image, Custom Menu', 'ambiense'); } ?>

This topic contains 11 replies, has 2 voices.

Last updated by gorkemA 3 months ago.

Assigned support staff: Bruno Kos.

Author Posts
July 19, 2019 at 7:24 am #4244503

gorkemA

I am trying to create multi language website. I created English version but I can't see in the footer part on the Turkish version.

Link to a page where the issue can be seen:hidden link

I expected to see:hidden link

July 19, 2019 at 7:58 am #4244761

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

According to this image, it seems like that you don't have any widgets set show in another language. Can you try the following?
https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

Each widget has a Display on language option with a drop down menu. You can select to display the widget for all languages or a specific one. By default, widgets are displayed on all languages.

So try duplicating the widget and then setting it to show on a different language.

Regards,
Bruno Kos

July 19, 2019 at 8:26 am #4244887

gorkemA

I did it but still doesn't work it. That's why I write to you.

July 19, 2019 at 8:40 am #4244957

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup

Regards,
Bruno Kos

July 19, 2019 at 9:07 am #4245097

gorkemA

I have another problem. For example,I'm using slick pop up and contact form plugin. How can I translate these plugins?

Thanks,
Burak

July 19, 2019 at 9:35 am #4245353

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

From what I see, there is nothing wrong set here, so I'm not sure what's going on, could be a compatibility issue. I see that the theme creates several footer areas - one for each language if I'm not mistaken.

Therefore, may I ask you to install the theme here?

Login: hidden link
Username: demo
Password: 87KUl0cUpVc1

And setup the same WPML languages as they are on your site, along with having the same theme settings for the homepage. We need nothing else, don't add any other plugins (only what is required for the theme).

If we see the same behavior here, I will escalate this to our compatibility team for further inspections.

Let me know if you have some questions related to this!

Regards,
Bruno Kos

July 19, 2019 at 9:51 am #4245487

gorkemA

Ok, I uploaded theme. I am waiting your answer now 🙂

Thanks,
Burak

July 19, 2019 at 10:27 am #4245681

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Burak,

It seems like this is a compatibility issue after all :(.

Therefore, I have sent this to our compatibility team for further inspections. I will keep you posted once they reply back!

No matter what I do, widgets only show on English language. The widgets will only show up in hidden link, and not in other languages such as hidden link

So it is not about WPML default language, but it seems to be about languages in general, because it only works in English.

Regards,
Bruno Kos

July 19, 2019 at 10:58 am #4245903

gorkemA

Hi Bruno,
Thanks for the reply, I hope this problem solve as soon as possible because I have to finish this project today.I'm waiting your compatibility team answer.
Thanks,
Burak

July 19, 2019 at 12:07 pm #4246219

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I cannot give you dates on when will they fix this, because it may be a bigger issue or even require help from the theme developers. Whether it will be to today, I cannot guarantee, not rarely compatibility issues take much longer than that and it also depends on their current workload.

Regards,
Bruno Kos

July 19, 2019 at 12:19 pm #4246337

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you try this?

in wp-content/themes/ambiense/include/footer-bars.php replace line 9:

<?php if(is_active_sidebar("ozy-footer-widget-bar-full" . $tmp_lang)) { if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar("ozy-footer-widget-bar-full" . $tmp_lang) ) : ?><?php endif; }else{ esc_attr_e('&copy; ', 'ambiense');echo date('Y'); echo ' ' . get_bloginfo('name');esc_attr_e(', Please go to Appearance > Widgets : Footer Bar Full Width and add some widgets here, e.q; Image, Custom Menu', 'ambiense'); } ?>

with

<?php if(is_active_sidebar("ozy-footer-widget-bar-full")) { if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar("ozy-footer-widget-bar-full") ) : ?><?php endif; }else{ esc_attr_e('&copy; ', 'ambiense');echo date('Y'); echo ' ' . get_bloginfo('name');esc_attr_e(', Please go to Appearance > Widgets : Footer Bar Full Width and add some widgets here, e.q; Image, Custom Menu', 'ambiense'); } ?>

It works on our setup:
hidden link

Regards,
Bruno Kos

July 20, 2019 at 10:36 am #4249585

gorkemA

My issue is resolved now. Thank you!