This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Otto 1 year, 3 months ago.

Assigned support staff: Otto.

Author Posts
March 23, 2018 at 12:12 pm #1554989

adriO

Hi Otto,
I stumbled into something (maybe) similar but more urgent than the other issue.

In the site is a support forum. For that forum I have activated three widgets.
1) Search, 2) Recent topics 3) Recent replies.
The widgets are set to show in all languages.

The widget for the recent topics is not showing on all of my English pages, which is my second language.
When I set the site to Dutch all widgets are showing on all pages.

Any idea?

See screenshots.

March 23, 2018 at 1:41 pm #1555090

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

This was working fine before we enabled the fallback option? If you translate a topic does the widget shows?

If it does not, is it possible for you to do this test:

***Backup your site and DB before proceeding***

-Deactivate all the plugins but WPML and its add-ons, keep all the other plugins that are necessary to reproduce the issue
-Switch to a default WP theme (Twenty Sixteen for example)
-If the issue is gone, reactivate one at a time to see with which one is the conflict

If it is not possible or if the issue persists, I'd like to replicate your site locally.

Can you provide me with a copy of your site? You may use the Duplicator plugin or just provide a copy of the DB + wp-content folder, excluding uploads to reduce the size.
 
If you will use Duplicator, remember to enable the filters and exclude this:
+ wp-uploads
+ cache
+ media
+ archive
 
Excluding these things will help in keeping the snapshot size minimum
 
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
 
Once the problem is resolved I will delete the local site.
 
I am enabling private message for your next reply so that you can send me snapshot link.
 
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Thanks!

Kind regards,

Otto
 

March 26, 2018 at 10:54 am #1556430

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

Thanks!

As far as I can see the widget that is not showing is the one that is showing the recent comments.

As explained here:
https://wpml.org/forums/topic/just-a-few-pages-in-a-second-language/#post-1554061

this is expected as there are no comments in English.

The forum replies widget is showing properly in all languages if I am not mistaken. Check it here:
yourpath/en/forums/topic/een-testonderwerp/, "RECENT FORUM REPLIES"

If I am not understanding the issue properly, can you please elaborate a bit so I can better understand?

Kind regards,

Otto

March 26, 2018 at 11:27 am #1556470

adriO

Hi Otto,
Thank you for your reply.
Just this morning I discovered that there was also something wrong with the topics and the replies in the forum. Sometimes it was shown in Dutch and sometimes it was shown in English.

I dived again in Translation Managment -> Configure Multi Lingual Content and reviewed the settings again.

I changed some settings back and forth and it appears to be ok when the settings are as in the attached screenshot. Why? I really don't know. I have changed it a lot of times so I did forget what the initial state was. If you want to compare, you can see this initial settings in the package I send you. They may be different, at least it seems to be working correctly....

As far as I can recall it Ichanged it from the fallback to "not translatable"

About the recent comments. I just set them to show only on Dutch pages. When all languages is checked the widget title is shown but no content in it. Like you explained to me.

When it is ok with you I want to leave this ticket open for a little while. I want to do some more testing. When I'm confident enough that the settings and the displaying is ok I will mar it as resolved.

Thank you very much for your help until now.

Best wishes,

Adri

March 26, 2018 at 12:52 pm #1556575

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

I am glad it is working now.

I tested your site with the fallback option for forums, topics and replies and it was working fine, as far as I can see. What issues were you having?

Anyway, if it is working fine with those settings, feel free to keep them 🙂

The ticket will remain open for two weeks without activity. If our friendly bot emails you that the ticket is about to close and you need more time, just write it here.

Kind regards,

Otto

April 3, 2018 at 5:42 am #1562854

adriO

It seems to be working now. Although I'm not very confident about it because the behaviour seems to be changing at will..... for now ok and when I need more help I open a new ticket.

Thanks for the help and bye for now.

April 3, 2018 at 11:47 am #1563289

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

I am glad it is working now.

Take into account that the fallback option it only works to the default language.

This means that if you create a post in the secondary language, it won't show as translated in the default language, nor in any other language.

Just wanted to mention as this may be the reason for the erratic behavior.

Kind regards,

Otto