This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WooCommerce widgets are not appearing in other languages even though they are set to show on all languages.

Solution: 1) Go to WPML > Settings > Post Types Translation. Set the "Product" Post type as "Translatable - only show translated items".

2) Go to the untranslated product you want to leave as untranslated and select the option "Duplicate" under the "Translate this Document" setting which is located in your product's "Language" tab.

you need to make sure not only the product is translated but also the categories, attributes and pretty much everything that WooCommerce filters get as parameters (price, categories, attributes, etc)

This topic contains 8 replies, has 2 voices.

Last updated by vilnisZ 11 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
October 26, 2018 at 10:47 am #2852814

vilnisZ

Hello,

So in /product-category/the-category/?lang=lv the widgets are not showing (they are specified to show in all languages) I tried to add new ones - and they are not showing too ether specified in one language or in all.

October 26, 2018 at 5:55 pm #2853942

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

I tried replicating the issue but couldn't. On my installation, it works without issues.

I would like you to deactivate WPML and test if the sidebar appears. If it doesn't appear there either, then the problem is either a theme problem or a configuration problem (most likely).

I would like you to follow this instructions and then let me know if the problem is solved:

1) Activate WPML

2) Go to Globe > Layouts > Product Categories > Click "Product categories"> Scroll down to the new "Layouts" Categories and select the desired Layout and assign it the desired sidebar.

Now, check if the sidebar has appeared.

Please let me know if this has solved your problem or if you have any doubts regarding this procedure.

October 29, 2018 at 7:39 am #2857037

vilnisZ

If I deactivate WPML then I don't have the Latvian language anymore to test with. The problem is only in that language.

For example this link: hidden link

In LV language the widgets are not showing. Switch to english - the widgets are showing.

October 29, 2018 at 2:42 pm #2858457

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I tried to reproduce your issue on a clean installation without success, so we'll have to move to the next step.

❌ Before proceeding please make a full website backup! ❌
⌥ You can use a plugin for this.
See: https://wordpress.org/plugins/duplicator/

I suggest you update all your WPML plugins to their last versions and then please, kindly give me access to your site so i can take a closer look at it.

I just enabled a private reply with custom fields where you should add the credentials to your site. only you and i will be able to see this new reply.

If you have any doubts on this process, let me know and i will gladly try to explain it in a different way.

October 30, 2018 at 8:15 am #2860752

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

By checking your site i see one issue that is probably the cause of the widget filters not showing.

Some of your products are not really translated but they're set as "Appear as translated" (for example: "All Test" and "Color" Products).

Now, they don't have a translation, so even though they're visible to the users in every language, the filters don't have a way of knowing those products are actually there (because in the database, they're just the original language product but visible everywhere).

When there aren't products to display, the filters just disappear (because that's their normal behavior, they appear only when there are products to be filtered), leaving you, in this case, with an empty widget.

To fix that problem i suggest you:

1) Go to WPML > Settings > Post Types Translation. Set the "Product" Post type as "Translatable - only show translated items" (this way you avoid these sorts of issues in the future).

2) Go to the untranslated product you want to leave as untranslated and select the option "Duplicate" under the "Translate this Document" setting which is located in your product's "Language" tab.

you need to make sure not only the product is translated but also the categories, attributes and pretty much everything that the filters get as parameters (price, categories, attributes, etc)

The filters will now start working correctly, thus, showing everywhere when necessary!

Let me know how it goes.

October 30, 2018 at 3:06 pm #2862404

vilnisZ

Oh, I understand now.

But I have a hook now that duplicates product in all languages when posted. So If categories and everything else is translated. Then it should work right?

I just have to delete all products and start fresh.

October 30, 2018 at 3:46 pm #2862570

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Exactly, Everything should work correctly if categories and everything else are either translated or duplicated.

I hope i made myself clear, otherwise don't hesitate to let me know and i'll do my best to find another way to explain it to you.

October 31, 2018 at 7:29 am #2864575

vilnisZ

Yes, it works that way! Thanks!

October 31, 2018 at 7:30 am #2864576

vilnisZ

My issue is resolved now. Thank you!