This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by pilarC-4 1 week, 5 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 30, 2019 at 6:27 pm #4667195

pilarC-4

I am trying to: I went to the Spanish section of my page and changed the widget text and saved it. This then overwrote the English widget and now both widgets are in Spanish. This has spoiled my SEO ranking for some posts.

I searched the issue in your forum and there is instructions to go to the widget area and add some conditions but my wordpress does not have a widget area menu item.

Link to a page where the issue can be seen:hidden link well you cannot see the issue now as I have deleted the Spanish text from here are it is messing with my SEO rankings but this is the reason why there is no text

I expected to see: Each language section with the corresponding language on the widget area.

Instead, I got:

September 30, 2019 at 9:19 pm #4667571

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

October 1, 2019 at 5:38 am #4668809

pilarC-4

Hello Marcos,

I have just sent you a message with my login credentials. I hope you get it. Otherwise you ask me to resend.
Just checking as I did not get any "sent" notification.

Thanks,
Pilar

October 1, 2019 at 4:13 pm #4673921

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Pilar,

Thank you for the updates. I checked your issue and see you made your text widget (the widget you show your introduction text) to appear just in spanish language from your WordPress Dashboard > Appearance > Widget settings, you can either add another text widget, enter the english text and set it to appear just in english or you can use the WPML String Translation addon and then translate your widgets to any language you want.

You can learn the full details on how to use the String Translation feature with these instructions:

1 - https://wpml.org/documentation/getting-started-guide/string-translation/

2 - https://wpml.org/documentation/getting-started-guide/translating-widgets/

Please, let me know if the instructions above are enough or you need any further clarifications and details, I am happy to help you with all the needed steps to make your widgets to appear the way you intend. Have a nice day.

October 2, 2019 at 7:29 am #4677469

pilarC-4

My issue is resolved now. Thank you!