This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 26, 2018 at 3:00 pm

Patrick

I am trying to: Edit my widgets

Link to a page where the issue can be seen: hidden link

I expected to see: The editing surface of the widget

Instead, I got: the widget surface will no longer expand so I cannot therefor edit the widgets.

I have backtraced this issue to the WPML plugin by disabling all the addons and placing the theme back to the twenty seventeen. Than re-enabling each addon one by one. The widgets work untill I activate the wpml sitepress plugin than I can no longer edit the widgets since they won't open up anymore.

So I can securely say that the theme is not the problem I hope someone can help me out here.

September 27, 2018 at 8:55 am #2769835

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

To further debug the problem I need to replicate your site locally.

I downloaded the duplicator package and will get back to you as soon as I have more information on this.

September 27, 2018 at 5:35 pm #2771396

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for waiting!

I practically created an exact duplicate of your site on my local. However, I am not able to replicate the issue as the widgets open and close without any issues whenever they are clicked (I am attaching a screenshot, too).

By looking into the debug information you provided, I can see that the WP Memory Limit for your site is currently 64M.

Could you please increase your Memory Limit and WP Memory limit to 256M?

Your current values are:
- MemoryLimit 256M
- WP Memory Limit 64M

128M is the minimum WP Memory Limit required by WPML.

You can add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/

Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

If this does not help, please take these next steps:

❌ Before proceeding please make a full website backup! ❌

1. Deactivate all the plugins but WPML and its add-ons
2. Switch to a default WP theme (Twenty Sixteen for example)
3. If the issue is gone, reactivate one plugin at a time to see with which one is the conflict

Let me know your results, please.

September 28, 2018 at 10:45 am #2773289

Patrick

Hey there,

I've tried everything you've suggested, edited the wp-config to increase the wp-memory.
I've disabled every other plugin on the website and changed the theme to 2016.
However my widgets are still not opening for me. Perhaps you could login to the website with the credentials I have provided and see if you can find the issue there?
I am at a loss here because so far the website has Always worked fine, I had not changed anything when it just stopped from one day to another. The widgets work fine untill I have wpml activated than they just stop opening. But this website really needs wpml to function because of the custom fields used to show the content which are translated by wpml.
So any help you can give me with this will be a great addition thanx for taking the time so far!

October 1, 2018 at 12:07 pm #2778027

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

If the steps you took did not solve the issue and as I could not recreate the issue on my local setup, this might be a possible hint telling us that what is causing this might be related somehow to the server setup your site is using.

The difference between my local install and your site is mainly the PHP version.

As it can be seen here (hidden link), there's no more support for the PHP versions that are under v5.6.

The only way to exclude a lot of presumptions is for you to recreate this issue on a clean WordPress install.

Updating your server's PHP version to v5.6 or, better, to PHP 7.1.x, might solve the issue.

You can also try to recreate the issue on this staging I created especially for you (hidden link). It is a one-click login so you don't need to remember any user or pass, just click the link.

Please try any of these 2 options and let me know the results.

October 8, 2018 at 1:58 pm #2796305

Patrick

Hello again,
I'm sorry for the delay, I had requested with my hosting provider to switch the website to a stronger server to provide the resourced you suggested.
Now after a week the website has been migraited to a new server, I have even attempted to renew the website by completely deleting it and placing the duplicator back-up I provided you with back. So with a fresh and clean install I have again attempted to get rid of the hacked widgets that cause the spam on the website. Unfortunately even with the new server and upgraded resources as soon as I active wpml sitepress plugin my widgets admin stops working. I am at a loss here, my hosting assured me it's not an error on their side and that they can no longer do anything more than they have already offered. I have made sure that it's not a theme or plugin incompatibility by only putting wpml on it and no different plugins still same issue. So please, help me figure this out? The only thing I have not been able to upgrade is the php version of the website. Please help!

October 8, 2018 at 3:26 pm #2796677

Patrick

As extra edition I have put the website on a php 7.0 version however the problem still persists.

October 9, 2018 at 2:06 pm #2800363

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello,

I would need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

The topic ‘[Closed] Widgets will no longer expand’ is closed to new replies.