This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bobby 2 months ago.

Assigned support staff: Bobby.

Author Posts
August 14, 2019 at 12:51 pm #4394909

maxL-15

If I translate a field and click save in WPML > Taxonomies > Categories, normally it closes automatically after it saved. But it stays open and removes all the fields I filled in. It is still saving it, but it takes more time to click X every time. Can we fix this?

August 14, 2019 at 1:01 pm #4394977

maxL-15

I also need to refresh the page every time I added a new translation to see which ones are done and which ones are not. At other places in the site it just updates it immediately.

August 14, 2019 at 7:02 pm #4397109

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There ,

i just test this behavior on my staging environment and i was not able to reproduce it

Going to WPML->Taxonomies Translation->Categories , once i translate a field and save the window indeed does close

=> There is a set of ajax calls that takes place during this procedure, if possible please try the following

right click -> inspect -> network tab (on chrome) , then filter by XHR and clear

with a clear networks tab translate your category and then save, send me a screenshot of your results .

Do you get any errors ?

If you go to WPML->Languages which URL Format structure are you using ? and also scroll down and enable "Store a language cookie to support language filtering for AJAX "

August 15, 2019 at 8:36 pm #4403313

maxL-15

Hi Bobby,

Another issue likewise. I am translating all the blog posts. It worked for the first 2. Now I am translating the third post but none of them are saving anymore. I have to wait forever and it still doesn't publish. I need to translate every time again when trying to save it. It also gives an error that the automated backup is different than the one of the post or so. I also received an e-mail with the following, maybe it has to do something with it:

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In diesem Fall hat WordPress einen Fehler in einem deiner Plugins, WPML Translation Management, abgefangen.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

Bitte kontaktiere dein Hosting-Unternehmen, um Unterstützung bei der weiteren Untersuchung dieses Problems zu erhalten.

If your site appears broken and you can't access your dashboard normally, WordPress now has a special "recovery mode". This lets you safely login to your dashboard and investigate further.

hidden link

To keep your site safe, this link will expire in 1 Tag. Don't worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

Fehler-Details
==============
Ein Fehler vom Typ E_ERROR wurde in der Zeile 183 der Datei /var/www/vhosts/loomanit.nl/crystal.loomanit.nl/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-icl-translations.php verursacht. Fehlermeldung: Uncaught InvalidArgumentException: No translation entry found for query: s:34:" trid = %d AND language_code = %s ";a:2:{i:0;s:5:"55116";i:1;s:2:"at";} in /var/www/vhosts/loomanit.nl/crystal.loomanit.nl/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-icl-translations.php:183
Stack trace:
#0 /var/www/vhosts/loomanit.nl/crystal.loomanit.nl/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-icl-translations.php(67): WPML_TM_ICL_Translations->select_translation_id(' trid = %d AND ...', Array)
#1 /var/www/vhosts/loomanit.nl/crystal.loomanit.nl/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-icl-translations.php(43): WPML_TM_ICL_Translations->build_from_trid(Array)
#2 /var/www/vhosts/loomanit.nl/crystal.loomanit.nl/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-records.php(157): WPML_TM_ICL_Translations->__construct(Object(WPML_TM_Records), Array, 'trid_lang')
#3 /var/www/vhosts/loomanit.nl/crystal.looma

August 16, 2019 at 7:21 pm #4407969

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 16, 2019 at 7:23 pm #4407973

maxL-15

Hey bobby, don't ask me how, but today I tried again and worked 🙂

I have opened another ticket, can you please answer that one before the weekend goes off? It's a little thing so that we can go live with the site this weekend.

Thanks in advance!

August 16, 2019 at 10:35 pm #4408343

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

glad to hear that it is all working now , i reviewed your new ticket and can see that my colleague has taken over your new ticket 🙂