Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by vaidaK-2 1 year, 9 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 25, 2019 at 8:01 am #3238183

vaidaK-2

Tell us what you are trying to do? My website default language is Norsk, other English. I want to translate Widget section titles. As I enter string translation widget section in WPML, I see that language of titles (flag) is English, text - Norsk, as I press translate, there is written that I have to write word in Norsk. If I write English translation, i get widget titles translated in default language. Some how it work in a opposite way. In Norsk version, widget title become English.

Is there any documentation that you are following? I followed video tutorial working with translation of my web.

Is there a similar example that we can see? no

What is the link to your site? hidden link

February 25, 2019 at 7:04 pm #3241701

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please let me know if the site had a different default language when you first set up WPML on your site? Did you change it after or Norsk was the default one from the very beginning?

Also, I see that you are using "Assume that the original language of all strings is English" so that might be why you are seeing the flags in English.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 26, 2019 at 3:07 pm #3245626

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

HI.

I see.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. After you create a full backup of the site and follow the steps above, please install all the plugin updates here: hidden link

Please let me know when that's done so that I can continue on the debugging process.

Kind regards,
Mihai

March 1, 2019 at 7:35 am #3258709

vaidaK-2

Hi, why my web menu now is in English language in both versions - Norsk and English? What's happened? Could you check and solve asap?!!!! I increased WP memory and started working on other steps, you recommended. I will let you know then i am done.

March 1, 2019 at 8:43 am #3258959

vaidaK-2

I've done all things, you recommended. Could you please solve my issue asap, especially with menu language. It is very important. Thanks.

March 1, 2019 at 6:58 pm #3262846

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

Thank you for following the steps and for updating me.

1. Regarding the widgets translation, I think it would be even simpler if you use the steps here:
https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

The normal steps to translate the widgets can be found in the link below but I think the method in the link above is easier to follow:
https://wpml.org/documentation/getting-started-guide/translating-widgets/

2. Regarding the menu, from what I can see, there is one menu in English and one menu in Norwegian. Instead of this, it should be created one single menu in the default language and then you should use the steps below to create a translation of that menu:
https://wpml.org/documentation/getting-started-guide/translating-menus/

I changed the menu to the Norwegian language but you would need to translate that menu into English.

You practically need to go here (hidden link) and follow the steps in the documentation.

I'm also attaching some screenshots.

Please let me know how that goes.

Kind regards,
Mihai

March 4, 2019 at 9:31 am #3267713

vaidaK-2

It seems that is ok now with menu items. But widget problem is the same:
1. If I use first way of your recommendation: to use setting in WordPress Widget area and use one of the languages, then i just turn off on of the languages, I need both to be shown: English in English version, Norsk in Norsk version.
2. If I go to WPML String translation, my default (Norsk) language words has English flag next to it and if I do translation, it works in opposite way. THE SAME SITUATION AS IT WAS IN THE BEGINING.

March 4, 2019 at 4:47 pm #3269975

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I'm very happy that we solved the menu situation! 🙂

Regarding the widgets, there is also the option where you can change the main language of that string so that they will stop being the opposite.

Please take a look at the screenshot I attached.

You can change the default to be Norwegian so the other language will become English.

Please let me know if this solved your issue or if you still need help. 🙂

I will be waiting for your response.

Kind regards,
Mihai

March 5, 2019 at 6:50 am #3271808

vaidaK-2

YES YES!!! This is exactly what I needed! Thank you!!!

March 5, 2019 at 10:36 am #3272892

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi!

I am soooo happy to hear that this solved the issue 🙂

Can you also please mark this ticket as resolved, too?

Thank you and please come back with a new ticket whenever you need help!

We are more than happy to help. 🙂

Kind regards,
Mihai

March 5, 2019 at 10:39 am #3272913

vaidaK-2

My issue is resolved now. Thank you!