Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: What can I do to optimize WPML performance and increase website speed?

Solution: WPML 4.3 version solved the performance issues that some sites experienced. Updating to the latest version of WPML and its add-ons should resolve the problem.

If you are still running into performance problems, first follow our FAQ entry about preventing performance issues with WPML. This FAQ includes a number of simple steps to follow.

In case you want to profile your site's performance and get to the bottom of performance problems, follow the guide for debugging performance problems.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 7 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 19, 2019 at 5:05 pm

marcoT-30

Hi, I have spent at least 1 month to optimize my site and sadly I have discovered that I lost only time because the problem was WPML!!

I have read and applied all solutions found in the forum without success. I'm confident you will find a solution before to switch to another product.

I have made my own investigations and I have discovered that the Wpml execute tons of slow queries for every loaded page!

Query monitor reported me a dozen of slow queries executed from string-translation and cms. For example:

With WPML:
Load hidden link -> 649 queries
Load hidden link -> 663 queries
Load hidden link -> 480 queries

Without WMPL:
Load hidden link -> 243 queries (!)

hidden link -> This is a copy of my site (hidden link) installed in a fresh Vps (I was thinking the main speed problem was SiteGround...)

Please don't tell me use a cache plugin because I already used and made other optimizations without a significant results.

Without WPML some times the load speed of my home page is under 1 second (Europe server) or max 2 sec. With WPML is 4/6 sec. and variable, with a few connected users and in some case 7/10sec. (!).

This huge amount of slow queries have a very bad impact in any server.

Regards
Marco

July 20, 2019 at 12:34 pm #4249857

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Marco,
Thank you for contacting us again.

In this case I would like to ask your authorization to sun some tests in the site and try to isolate the cause of the issue.

Please confirm that you made a full backup of the site.
Regards,
Carlos

July 20, 2019 at 2:09 pm #4250069

marcoT-30

Yes do what you want is a copy of the original site just to do tests.

Marco

July 21, 2019 at 4:36 pm #4252733

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Marco,
Thank you very much for your authorization.

I flushed the cache memory in the site and ran some WPML troubleshooting steps. After that I visited the site on incognito mode and here are my results (see attached images). The load times seems to be under the normal range for a site with this characteristics.

Note: I'm getting a 500 error in the front end after deactivating/activating all plugins. Could you solve this 500 error?

Regards,
Carlos

July 21, 2019 at 4:41 pm #4252825

marcoT-30

Hi Carlos and good sunday. We are working togeter in the site.

I don't know what is happened but the site was running fast and fine this afternoon.

I investigate. Today have you made some optimizations?

July 21, 2019 at 4:42 pm #4252827

marcoT-30

Today I have activated WP Total Cache and I have removed a lot of strings in the translator.

July 22, 2019 at 11:39 am #4256731

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Marco,
Thank you very much for your messages and good monday 🙂

Do you have any update regarding the performance issue in the site?

Regards,
Carlos