This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.49 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by Bruno 8 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
December 28, 2018 at 6:23 pm #3041003

tawfiqM

Tell us what you are trying to do?

Is there any documentation that you are following?

Is there a similar example that we can see? you can visit my site and you can see some of page empty

What is the link to your site? hidden link

December 28, 2018 at 6:42 pm #3041029

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

What exactly happens on your site? Are any error messages appearing?

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Also, please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

December 28, 2018 at 8:26 pm #3041159

tawfiqM

Hi Bruno,

as you see from my site, hidden link, if wpml active i cant see all my page, but if wpml not active i can see all my page open.

you can see this link photo online
hidden link - if WPML not active website work normal
hidden link - if WPML active

December 29, 2018 at 4:24 am #3041715

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for the detailed explanation. This may be some compatibility issue.

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

January 2, 2019 at 1:37 pm #3049329

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. This seems to be a compatibility issue. This happens when the "locations" option is set to be translatable on the WPML > Settings > Post type translation.

To ensure that this theme is made compatible with WPML we need to contact the theme author and work with him on resolving the issue.

I have forwarded the details to our Themes & Plugins Compatibility Team and they will contact the author. Our Compatibility Team will work with the author of the plugin for this to work properly.

Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

Thank you.

January 21, 2019 at 5:35 pm #3113507

tawfiqM

hello
we are still waiting

January 21, 2019 at 6:50 pm #3113776

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. I am in contact with our compatibility team so they can check again.

Thank you.

January 31, 2019 at 3:59 pm #3148654

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Our compatibility team has created a workaround for the site to work properly:

- Open the file wp-content/themes/BookYourTravel/includes/post_types/class-location-helper.php line 348
- Comment this line (Add "//" at the beginning of the line)
- Save the changes and upload the changed file

OR

- Open the file wp-content/themes/BookYourTravel/includes/post_types/class-location-helper.php line 317
- replace the line:

suppress_filter => false

to

suppress_filter => true

- Save the changes and upload the changed file

That should be the problem. After following these steps, please let me know if your site is working properly

Thank you.